<!DOCTYPE html>
<html lang="en-CA" data-amp-auto-lightbox-disable transformed="self;v=1" i-amphtml-layout="" i-amphtml-no-boilerplate="" i-amphtml-binding>
<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012206101637000">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</style><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it - Alberta Politics"><meta property="og:description" content="The rodeo, town officials, and the people who rode on the embarrassing float should all take the Dashmesh Culture Centre up on its offer. There’s contact information on the centre’s website."><meta property="og:url" content="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/"><meta property="og:site_name" content="Alberta Politics"><meta property="article:author" content="https://www.facebook.com/david.climenhaga.7"><meta property="article:published_time" content="2022-06-28T06:46:34+00:00"><meta property="article:modified_time" content="2022-06-28T15:11:58+00:00"><meta property="og:image" content="https://albertapolitics.ca/wp-content/uploads/ParadeFloat.png"><meta property="og:image:width" content="1198"><meta property="og:image:height" content="675"><meta property="og:image:type" content="image/png"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="David Climenhaga"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="5 minutes"><meta name="generator" content="WordPress 5.9.3"><meta name="generator" content="Site Kit by Google 1.75.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-title" content="ABPol"><meta name="application-name" content="ABPol"><meta name="generator" content="AMP Plugin v2.3.0; mode=standard"><meta name="msapplication-TileImage" content="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=270%2C270&amp;ssl=1"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//v0.wordpress.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="preload" href="https://albertapolitics.ca/wp-content/plugins/jetpack/_inc/social-logos/social-logos.eot?5d3b4da4f6c2460dd842dbf9e0992ea6#iefix" as="font" crossorigin=""><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin=""><link rel="dns-prefetch" href="https://fonts.gstatic.com"><script type="module" src="https://cdn.ampproject.org/v0.mjs" id="amp-runtime-js" async crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0.js" crossorigin="anonymous"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-access-0.1.mjs" id="amp-access-js" async custom-element="amp-access" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-access-0.1.js" crossorigin="anonymous" custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.mjs" async="" custom-element="amp-analytics" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" crossorigin="anonymous" custom-element="amp-analytics"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-bind-0.1.mjs" id="amp-bind-js" async custom-element="amp-bind" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" crossorigin="anonymous" custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.mjs" async="" custom-element="amp-form" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-form-0.1.js" crossorigin="anonymous" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.mjs" async="" custom-element="amp-install-serviceworker" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" crossorigin="anonymous" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-lightbox-gallery-0.1.mjs" async="" custom-element="amp-lightbox-gallery" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-lightbox-gallery-0.1.js" crossorigin="anonymous" custom-element="amp-lightbox-gallery"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.mjs" async="" custom-template="amp-mustache" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" crossorigin="anonymous" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.mjs" async="" custom-element="amp-sidebar" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" crossorigin="anonymous" custom-element="amp-sidebar"></script><link rel="icon" href="https://albertapolitics.ca/wp-content/uploads/cropped-abpoli-150x150.png" sizes="32x32"><link rel="icon" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="canonical" href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://albertapolitics.ca/#website","url":"https://albertapolitics.ca/","name":"Alberta Politics","description":"David Climenhaga\u0026#039;s Alberta Politics Blog","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://albertapolitics.ca/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","inLanguage":"en-CA","@id":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#primaryimage","url":"https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?fit=1198%2C675\u0026ssl=1","contentUrl":"https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?fit=1198%2C675\u0026ssl=1","width":1198,"height":675,"caption":"The offensive Sundre parade float (Photo: @Airdronian/Twitter)."},{"@type":"WebPage","@id":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#webpage","url":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/","name":"A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it - Alberta Politics","isPartOf":{"@id":"https://albertapolitics.ca/#website"},"primaryImageOfPage":{"@id":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#primaryimage"},"datePublished":"2022-06-28T06:46:34+00:00","dateModified":"2022-06-28T15:11:58+00:00","author":{"@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779"},"breadcrumb":{"@id":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/"]}]},{"@type":"BreadcrumbList","@id":"https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://albertapolitics.ca/"},{"@type":"ListItem","position":2,"name":"All News","item":"https://albertapolitics.ca/top-news/"},{"@type":"ListItem","position":3,"name":"A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it"}]},{"@type":"Person","@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779","name":"David Climenhaga","image":{"@type":"ImageObject","inLanguage":"en-CA","@id":"https://albertapolitics.ca/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96\u0026d=mm\u0026r=r","contentUrl":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96\u0026d=mm\u0026r=r","caption":"David Climenhaga"},"sameAs":["https://www.facebook.com/david.climenhaga.7","https://twitter.com/djclimenhaga"],"url":"https://albertapolitics.ca/author/david/"}]}</script><link rel="alternate" type="application/rss+xml" title="Alberta Politics » Feed" href="https://albertapolitics.ca/feed/"><link rel="alternate" type="application/rss+xml" title="Alberta Politics » Comments Feed" href="https://albertapolitics.ca/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Alberta Politics » A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it Comments Feed" href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/feed/"><link rel="https://api.w.org/" href="https://albertapolitics.ca/wp-json/"><link rel="alternate" type="application/json" href="https://albertapolitics.ca/wp-json/wp/v2/posts/44796"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://albertapolitics.ca/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://albertapolitics.ca/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/p5xfli-bEw"><link rel="alternate" type="application/json+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F06%2Fa-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it%2F"><link rel="alternate" type="text/xml+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F06%2Fa-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it%2F&amp;format=xml"><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" data-amp-plus-allowed data-amp-unvalidated-tag></script><script id="amp-access" type="application/json">{"namespace":"popups","authorization":"https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php?cid=CLIENT_ID(newspack-cid)\u0026ref=DOCUMENT_REFERRER\u0026popups=[{\"id\":\"id_43547\",\"f\":\"once\",\"utm\":null,\"s\":\"\",\"n\":true,\"d\":false,\"t\":\"i\",\"c\":\"custom1\"}]\u0026settings={\"active\":null,\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_donor_landing_page\":\"\",\"newspack_popups_mc_donor_merge_field\":\"DONAT\",\"newspack_popups_non_interative_mode\":false,\"all_segments\":{\"624a724f4180e\":{\"min_posts\":\"5\",\"max_posts\":0,\"min_session_posts\":0,\"max_session_posts\":0,\"is_subscribed\":false,\"is_donor\":false,\"is_not_subscribed\":false,\"is_not_donor\":true,\"favorite_categories\":[],\"referrers\":\"\",\"referrers_not\":\"\",\"priority\":0}},\"newspack_popups_active_campaign_group\":false}\u0026visit={\"post_id\":\"44796\",\"categories\":\"396\",\"is_post\":true}","noPingback":true}</script><link rel="manifest" href="https://albertapolitics.ca/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=192%2C192&amp;ssl=1"><link rel="pingback" href="https://albertapolitics.ca/xmlrpc.php"><link rel="apple-touch-icon" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=180%2C180&amp;ssl=1"><title>A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it - Alberta Politics</title></head>

<body class="post-template-default single single-post postid-44796 single-format-standard wp-custom-logo wp-embed-responsive singular hide-site-tagline h-nsub h-db h-ll h-dh h-stk has-tertiary-menu has-sidebar cat-alberta-politics-2 has-featured-image single-featured-image-default" data-amp-auto-lightbox-disable>
<svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-dark-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0.49803921568627"></fefuncr><fefuncg type="table" tablevalues="0 0.49803921568627"></fefuncg><fefuncb type="table" tablevalues="0 0.49803921568627"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.54901960784314 0.98823529411765"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.71764705882353 0.25490196078431"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-red"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 0.27843137254902"></fefuncg><fefuncb type="table" tablevalues="0.5921568627451 0.27843137254902"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-midnight"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0"></fefuncr><fefuncg type="table" tablevalues="0 0.64705882352941"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-magenta-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.78039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.94901960784314"></fefuncg><fefuncb type="table" tablevalues="0.35294117647059 0.47058823529412"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-green"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.65098039215686 0.40392156862745"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.44705882352941 0.4"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-orange"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.098039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.66274509803922"></fefuncg><fefuncb type="table" tablevalues="0.84705882352941 0.41960784313725"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg>		<div class="newspack_global_ad global_above_header">
						<div id="div-gpt-ad-d23a71ee67-0"></div>		</div>
			<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>

				<nav class="tertiary-menu nav3" aria-label="Tertiary Menu" toolbar-target="tertiary-nav-contain" toolbar="(min-width: 767px)">
			<ul id="menu-support" class="menu"><li id="menu-item-43562" class="menu-highlight menu-item menu-item-type-post_type menu-item-object-page menu-item-43562"><a href="https://albertapolitics.ca/donate/">Support Us</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://albertapolitics.ca/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
<section id="nav_menu-3" class="below-content widget widget_nav_menu"><h2 class="widget-title">Menu</h2><div class="menu-top-nav-container"><ul id="menu-top-nav" class="menu"><li id="menu-item-15918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-15918"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-15929" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-15929"><a href="https://albertapolitics.ca/top-news/" aria-haspopup="true" aria-expanded="false">All News</a>
<ul class="sub-menu">
	<li id="menu-item-43524" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43524"><a href="https://albertapolitics.ca/category/alberta-politics-2/">Alberta Politics</a></li>
	<li id="menu-item-43525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43525"><a href="https://albertapolitics.ca/category/canadian-politics/">Canadian Politics</a></li>
	<li id="menu-item-43526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43526"><a href="https://albertapolitics.ca/category/geopolitics/">Geopolitics</a></li>
	<li id="menu-item-43527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43527"><a href="https://albertapolitics.ca/category/st-albert/">St. Albert</a></li>
	<li id="menu-item-43528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43528"><a href="https://albertapolitics.ca/category/bestsellers/">Bestsellers</a></li>
	<li id="menu-item-43529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43529"><a href="https://albertapolitics.ca/category/guest-posts/">Guest Posts</a></li>
</ul>
</li>
<li id="menu-item-15936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15936"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26057"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li id="menu-item-32647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32647"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
<li id="menu-item-42009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42009"><a href="https://albertapolitics.ca/subscribe-to-newsletter/">Subscribe to Newsletter</a></li>
</ul></div></section>
	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>
<section id="nav_menu-3" class="below-content widget widget_nav_menu"><h2 class="widget-title">Menu</h2><div class="menu-top-nav-container"><ul id="menu-top-nav-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-15918"><a href="https://albertapolitics.ca/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-15929"><a href="https://albertapolitics.ca/top-news/" aria-haspopup="true" aria-expanded="false">All News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43524"><a href="https://albertapolitics.ca/category/alberta-politics-2/">Alberta Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43525"><a href="https://albertapolitics.ca/category/canadian-politics/">Canadian Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43526"><a href="https://albertapolitics.ca/category/geopolitics/">Geopolitics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43527"><a href="https://albertapolitics.ca/category/st-albert/">St. Albert</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43528"><a href="https://albertapolitics.ca/category/bestsellers/">Bestsellers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43529"><a href="https://albertapolitics.ca/category/guest-posts/">Guest Posts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15936"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26057"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32647"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42009"><a href="https://albertapolitics.ca/subscribe-to-newsletter/">Subscribe to Newsletter</a></li>
</ul></div></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'" i-amphtml-binding>

					
			<div class="middle-header-contain">
				<div class="wrapper">
											<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none" /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg>							<span>Menu</span>
						</button>
					
					
					
					<div class="site-branding">

	
		<a href="https://albertapolitics.ca/" class="custom-logo-link" rel="home"><amp-img noloading="" width="886" height="220" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?fit=886%2C220&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Alberta Politics" data-hero-candidate="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?w=886&amp;ssl=1 886w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=600%2C149&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=400%2C99&amp;ssl=1 400w" sizes="(max-width: 886px) 100vw, 886px" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIyMCIgd2lkdGg9Ijg4NiIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="Alberta Politics" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?fit=886%2C220&amp;ssl=1" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?w=886&amp;ssl=1 886w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=600%2C149&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=400%2C99&amp;ssl=1 400w" sizes="(max-width: 886px) 100vw, 886px"></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://albertapolitics.ca/" rel="home">Alberta Politics</a></p>
					
						<p class="site-description">
					David Climenhaga's Alberta Politics Blog				</p>
			</div>

</div>

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div>

											</div>

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none" /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg>							<span>Menu</span>
						</button>
					
				</div>
			</div>


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

											</div>
				</div>
					
					<div class="sticky-bg"></div>
			</header>

	
	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-alberta-politics-2 tag-alberta-politics tag-canadian-politics tag-dashmesh-culture-centre tag-town-of-sundre">
		<main id="main" class="site-main">

								<header class="entry-header">
						
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://albertapolitics.ca/category/alberta-politics-2/" rel="category tag">Alberta Politics</a></span>			<h1 class="entry-title ">
			A thought on how Sundre can start to put the embarrassment of the racist jackassery in its rodeo parade behind it		</h1>
		
	<div class="entry-subhead">
									<div class="entry-meta">
					<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=192&amp;d=mm&amp;r=r 2x" class="avatar avatar-96 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="96" width="96" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijk2IiB3aWR0aD0iOTYiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=192&amp;d=mm&amp;r=r 2x" height="96" width="96" loading="lazy"></noscript></amp-img></span><span class="byline"><span>by</span> <span class="author vcard"><a class="url fn n" href="https://albertapolitics.ca/author/david/">David Climenhaga</a></span></span><span class="posted-on"><time class="entry-date published" datetime="2022-06-28T02:46:34-04:00">June 28, 2022</time><time class="updated" datetime="2022-06-28T11:11:58-04:00">June 28, 2022</time></span>				</div>
								</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="1198" height="675" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?fit=1198%2C675&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?w=1198&amp;ssl=1 1198w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=1024%2C577&amp;ssl=1 1024w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 1198px) 100vw, 1198px" data-hero-candidate="" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjY3NSIgd2lkdGg9IjExOTgiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?fit=1198%2C675&amp;ssl=1" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?w=1198&amp;ssl=1 1198w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=1024%2C577&amp;ssl=1 1024w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/ParadeFloat.png?resize=400%2C225&amp;ssl=1 400w" sizes="(max-width: 1198px) 100vw, 1198px"></amp-img>			<figcaption><span>The offensive Sundre parade float (Photo: @Airdronian/Twitter). </span></figcaption>
			
			</figure>

		

<article id="post-44796" class="post-44796 post type-post status-publish format-standard has-post-thumbnail hentry category-alberta-politics-2 tag-alberta-politics tag-canadian-politics tag-dashmesh-culture-centre tag-town-of-sundre entry">
	<div class="entry-content">

		
		
<p>Surely there must’ve been a few folks in the Central Alberta town of Sundre who, when they noticed the racist jackassery of the now notorious “the Liberal” manure-spreader parade float on Saturday morning, thought, <em>“Oh no! Please, God, make them stop!”</em></p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="300" height="297" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?resize=300%2C297&amp;ssl=1" alt="" class="wp-image-44806 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?w=300&amp;ssl=1 300w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjI5NyIgd2lkdGg9IjMwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="300" height="297" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?resize=300%2C297&amp;ssl=1" alt="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?w=300&amp;ssl=1 300w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/MayClip.png?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px"></noscript></amp-img><figcaption>Someone was looking for a tractor to pull the float in May (Photo: Facebook/Lynn Hoff).</figcaption></figure></div>



<p>Alas, by the sound of it, no one spoke up.</p>



<p>Well, <a href="https://twitter.com/airdronian/status/1540804917148798977">one guy from out of town tweeted <em>“Yikes!”</em></a> But that was about it during the parade. </p>



<p>I imagine that there are several people in Sundre who now sincerely wish they’d said something, but for whatever reasons held their tongues.</p>



<p>Now that the story’s gone viral, despite all the other good things that may have happened in the Sundre Pro Rodeo Parade, folks from that place will be thought of as the embarrassing cousins of Confederation in many parts of the country and wise travellers from there, asked where they’re from, will say something like, “it’s just a little place in Alberta … <em>you’ve never heard of it</em>.” </p>
<aside class="scaip scaip-1    "><aside id="newspack-ads-widget-2" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-ad-62bbbf9b90c6a-0"></div></div></aside></aside>



<p>Folks in that part of Alberta don’t like Liberals, or New Democrats for that matter, so some still-mostly unidentified brainiacs thought it would be a great idea to dress up like Justin Trudeau and Jagmeet Singh and parade through town on the now-notorious manure-spreader pulled by a vintage John Deere tractor.</p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="250" height="320" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Gondek-2.png?resize=250%2C320&amp;ssl=1" alt="" class="wp-image-44805 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjMyMCIgd2lkdGg9IjI1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="250" height="320" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Gondek-2.png?resize=250%2C320&amp;ssl=1" alt=""></noscript></amp-img><figcaption>Calgary Mayor Jyoti Gondek (Photo: Facebook/Jyoti Gondek.)</figcaption></figure></div>



<p>That no one had the sense to recognize that a crude caricature of a Sikh man, complete with a tied-on beard and a mis-tied turban, does not send a very reassuring message about, among other things, what’s being taught in <a href="https://www.yellowpages.ca/search/si/1/Churches+%26+Other+Places+of+Worship/Sundre+AB">the nine or more Christian churches</a> that grace the town of about 2,500 located 90 kilometres northwest of Calgary. </p>



<p>The reaction, as the local paper put it, was fast and furious.</p>



<p>Sundre’s been taking a drubbing on social media ever since. Politicians from all points of the political compass have joined the condemnation of what the Dashmesh Culture Centre, a Sikh gurdwara and community centre in Calgary, called the “horrendous display of racism towards the Sikh community.”</p>



<p>“These kinds of acts have no place in Canada. This should be condemned in strongest terms by all,” said Jasraj Singh Hallan, the Conservative MP for Calgary Forest Lawn, speaking for most Albertans, I am sure. </p>
<aside class="scaip scaip-2    "><aside id="newspack-ads-widget-3" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-ad-62bbbf9b90fd4-0"></div></div></aside></aside>



<p>“Do better, people,” <a href="https://twitter.com/JyotiGondek/status/1541258659447025664">tweeted Calgary Mayor Jyoti Gondek</a>. </p>



<p>Faced with the wave of popular revulsion, about the best thing parade organizers and elected town officials could have done would have been to apologize sincerely and vow they’d never let anything like that happen again – and brace themselves for a reaction that might linger like radioactive fallout whenever the name of their town comes up. </p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="250" height="330" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Nixon-18.jpg?resize=250%2C330&amp;ssl=1" alt="" class="wp-image-44803 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjMzMCIgd2lkdGg9IjI1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="250" height="330" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Nixon-18.jpg?resize=250%2C330&amp;ssl=1" alt=""></noscript></amp-img><figcaption>Rimbey-Rocky Mountain House-Sundre UCP MLA Jason Nixon (Photo: David J. Climenhaga).</figcaption></figure></div>



<p>Jason Nixon, the United Conservative Party MLA for the riding <a href="https://twitter.com/JasonNixonAB/status/1541186217269555200">seemed to have the right idea</a>, saying “I strongly condemn the racist float that appeared in the Sundre parade.” </p>



<p>Parade and town officials didn’t do so well, though. <a href="https://twitter.com/airdronian/status/1540845389972025345/photo/1">A social media statement from the rodeo</a> did promise, “We do send our deepest apologies and something like that will NEVER HAPPEN AGAIN.”</p>



<p>But organizers were soon insisting that it wasn’t really their fault. “The entry was not approved and upon further investigation joined the parade without passing through any registration,” a statement insisted on the parade’s Facebook page. “To be clear it was NOT approved.”</p>



<p>The problem with this was that folks pay attention and soon started noting stuff that suggested otherwise. </p>



<p><em>MountainView Today</em>, a local news site, <a href="https://www.mountainviewtoday.ca/sundre-news/racialized-caricature-of-singh-and-trudeau-makes-sundre-parade-go-viral-for-wrong-reasons-5520170">ran a clear photo of the man</a> in the turban and fake beard wearing a VIP ribbon given out by parade marshals. </p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="250" height="338" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Jasraj-Singh-Hallan.jpg?resize=250%2C338&amp;ssl=1" alt="" class="wp-image-44804 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjMzOCIgd2lkdGg9IjI1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="250" height="338" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Jasraj-Singh-Hallan.jpg?resize=250%2C338&amp;ssl=1" alt=""></noscript></amp-img><figcaption>Calgary Forest Lawn Conservative MP Jasraj Singh Hallan (Photo: Facebook/ Jasraj Singh Hallan).</figcaption></figure></div>



<p>Organizers told <em>MountainView Today’s</em> reporter that the volunteers who handed out the tags didn’t know who was registered and who wasn’t – so, obviously, getting registered wasn’t a very meaningful process. </p>



<p>Another shot seen on social media shows the controversial entry <a href="https://albertapolitics.ca/wp-content/uploads/289772990_10159860738431063_3057765878574718154_n.jpg">lined up with others waiting for the parade to start</a>.</p>



<p>Pretty soon screen captures of a<a href="https://twitter.com/SumOfAllVeers/status/1541142349874507777"> Facebook post last month looking for someone with a tractor to pull the manure spreader</a> were posted. <a href="https://twitter.com/AlleyDalley/status/1541139905685749762/photo/2">Screenshots of conversation at the time</a> make it clear the plan was well known in the community – and that not everyone thought it was a good idea.</p>



<p>But tracked down by CTV as the controversy continued to boil over, the owner of the parade float <a href="https://calgary.ctvnews.ca/it-was-political-satire-lynne-hoff-discusses-her-controversial-parade-float-1.5965400">insisted the whole bad idea was just political satire</a>. “The last thing it was, was racist,” Lynn Hoff told the network. “… It wasn’t anything to do with the Sikh community.”</p>



<p>Well, that kind of comment isn’t going to help the town now or settle down the controversy. </p>



<p>A suggestion from the Dashmesh Centre, though, just might help Sundre start to put this controversy behind it. </p>



<p>“We need to have serious conversations and actions to stop these forms of racism,” <a href="https://twitter.com/DashmeshC/status/1540932638982123520">the centre said on its Twitter account</a>. “We welcome @SundreProRodeo and their parade committee to visit DCC and learn about Sikhs.”</p>



<p>The rodeo, town officials, and the people who rode on the embarrassing float should all take them up on their generous offer. There’s contact information on <a href="https://dashmesh.ca/">the centre’s website</a>. </p>
<section id="newspack-ads-widget-4" class="below-content widget widget_newspack-ads-widget"><div class="textwidget"><div id="div-gpt-ad-62bbbf9b91ff7-0"></div></div></section>	</div>

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://albertapolitics.ca/tag/alberta-politics/" rel="tag">Alberta politics</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/canadian-politics/" rel="tag">Canadian Politics</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/dashmesh-culture-centre/" rel="tag">Dashmesh Culture Centre</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/town-of-sundre/" rel="tag">Town of Sundre</a></span>	</footer>

	
</article>

<div id="comments" class="comments-area">
	<div class="comments-title-wrap">
		<h2 class="comments-title">
		Join the Conversation		</h2>
		
<div class="discussion-meta">
	<p class="discussion-meta-info">
		<svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.99 4c0-1.1-.89-2-1.99-2H4c-1.1 0-2 .9-2 2v12c0 1.1.9 2 2 2h14l4 4-.01-18z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span>10 Comments</span>
	</p>
</div>
	</div>
		
		
			<ol class="comment-list">
						<li id="comment-215594" class="comment even thread-even depth-1">
			<article id="div-comment-215594" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/2660bc2616ab9d6de4b16dd96db6e012?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/2660bc2616ab9d6de4b16dd96db6e012?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/2660bc2616ab9d6de4b16dd96db6e012?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/2660bc2616ab9d6de4b16dd96db6e012?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Dave</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215594">
														<time datetime="2022-06-28T03:33:54-04:00" title="June 28, 2022 at 3:33 am">
								June 28, 2022 at 3:33 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>Having come from a small town, I can understand how this embarrassing and terrible incident happened.  Smaller places can be quite insular and accordingly many there have odd and racist ideas about people from different backgrounds, not actually knowing or having met many people from different backgrounds.   Perhaps the intention was satire, or something like that, by people who didn’t realize or appreciate the racist implications of what they were doing, or perhaps they just didn’t care.</p>
<p>Yes, someone should have spoken up, or maybe that did happen and they were ignored or dismissed – that wouldn’t be surprising either.  The prevailing views in some of these places sometimes seems like a gang of crazy uncles.  So those who have better sense are sometimes either bullied into silence or fear they will become the next target of ridicule, so they do not speak up.  This is why things like this happen and places like Sundre are then forced to look into the mirror and see themselves as others might.  It is not pretty, but it can actually be an opportunity for reflection and learning.</p>
<p>There is a saying in politics about throwing dirt and losing ground.  Likewise if you are going spread political manure, maybe you will end up covered in it too.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215594" data-postid="44796" data-belowelement="div-comment-215594" data-respondelement="respond" data-replyto="Reply to Dave" aria-label="Reply to Dave" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Dave","commentParent":"215594"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215599" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-215599" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/393889b226f31bb7d74e6c005c324505?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/393889b226f31bb7d74e6c005c324505?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/393889b226f31bb7d74e6c005c324505?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/393889b226f31bb7d74e6c005c324505?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Just Me</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215599">
														<time datetime="2022-06-28T05:41:10-04:00" title="June 28, 2022 at 5:41 am">
								June 28, 2022 at 5:41 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>Considering that this is a rodeo in Sundre, AB, I wouldn’t be surprised if the organizers adopt a Most-Racist Float category for the next parade. All this incident demonstrated, to me, was that this is the sort of thing is what is spoken of but only in whispers in rural Alberta. It’s not usual to encounter this sort of nonsense in any part of rural Alberta, where it is invariably cheered and laughed at. Now that the organizers and others have denounced this, I can hear screams about Cancel Culture going full-tilt.</p>
<p>It’s like in a recent exchange I had with someone who’s too old and too white to care anymore. He was convinced that there is such a thing as Cancel Culture. To that I asked what it was and he replied that it was taking away everyone’s right to say whatever they wanted about anything they wanted. Okay, so it’s okay to yelled “Fire!” in a crowded place? He said it was a stupid thing to do, but it wasn’t that big a deal. Okay, so what about throwing around racist taunts that are clearly hate crimes. Old Boomer went on about people are “such pussies” these days. I noted he would say that because he’s old and white. At that point, he went full back-my-day rant about how the “snowflakes are ruining everything”. At this point my Wow-Meter was hitting some amazing numbers. Before he could go on with some Do-Your-Research thing he saw on Facebook, I excused myself because I was going to be late for a Pride event. I watched him shake his head as he walked away.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215599" data-postid="44796" data-belowelement="div-comment-215599" data-respondelement="respond" data-replyto="Reply to Just Me" aria-label="Reply to Just Me" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Just Me","commentParent":"215599"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215602" class="comment even thread-even depth-1">
			<article id="div-comment-215602" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/fc27a946e67934afce3dd08493b606b5?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/fc27a946e67934afce3dd08493b606b5?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/fc27a946e67934afce3dd08493b606b5?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/fc27a946e67934afce3dd08493b606b5?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Anonymous</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215602">
														<time datetime="2022-06-28T06:57:03-04:00" title="June 28, 2022 at 6:57 am">
								June 28, 2022 at 6:57 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>There are readers of your blog who do have rural backgrounds, including myself. I don’t think for a minute that this parade float could have been just snuck in. It was deliberately planned, and based on other information, it was set up far in advance of this parade. If you are from a small enough town, it’s quite impossible for you to do something like this, and not get noticed. There is also glaring hypocrisy here. The same people who condemn Justin Trudeau for wearing blackface, want to just brush this off. Also, this is not something that adults should be doing. I’m sure there are people who dressed up for Halloween, when they were a child, and when they got older, they regret what they dressed up as. We learn from experiences like that. Alberta is going to get ridiculed even more, because of different things, including this. There are parts of Alberta, where bigoted beliefs still exist with a segment of the population. Jason Nixon was at this parade. How did he not know what was transpiring sooner? Why didn’t he instantly condemn this stupid act? He condemned it a day later. If I recall correctly, Jason Nixon was the one who helped get a single mother fired, after she had raised issues of being harassed at her place of employment. This doesn’t help his credibility. The creator of this parade float doesn’t have any credibility either, let alone maturity. She is intent on bashing Justin Trudeau and Jagmeet Singh, for what she thinks they are doing wrong, but she will likely turn a blind eye to the very pricey shenanigans, and bad policies, that the UCP are doing, which ended up costing Alberta billions of dollars, and has even cost Albertans their lives, such as with Covid-19 pandemic response, and with healthcare related matters.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215602" data-postid="44796" data-belowelement="div-comment-215602" data-respondelement="respond" data-replyto="Reply to Anonymous" aria-label="Reply to Anonymous" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Anonymous","commentParent":"215602"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215605" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-215605" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/0f43cee5cfb7cd027bb6653490e84aa9?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/0f43cee5cfb7cd027bb6653490e84aa9?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/0f43cee5cfb7cd027bb6653490e84aa9?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/0f43cee5cfb7cd027bb6653490e84aa9?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							Political Ranger
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Political Ranger</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215605">
														<time datetime="2022-06-28T08:05:08-04:00" title="June 28, 2022 at 8:05 am">
								June 28, 2022 at 8:05 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>This province and the vast majority of people in it are an embarrassing joke. These people are as dumb and ignorant – and just plain mean spirited as they come. This place is a dirty miserable backwater and has always been so.<br>
As bad as things were during the Klien era when they persecuted Wiebo Ludwig, it’s gotten so much worse.<br>
Evil is not too strong a word to describe these people. Dark, dark forces across the land.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215605" data-postid="44796" data-belowelement="div-comment-215605" data-respondelement="respond" data-replyto="Reply to Political Ranger" aria-label="Reply to Political Ranger" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Political Ranger","commentParent":"215605"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215607" class="comment even thread-even depth-1">
			<article id="div-comment-215607" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/7849013f1da695a24e491f7e7b21a923?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/7849013f1da695a24e491f7e7b21a923?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/7849013f1da695a24e491f7e7b21a923?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/7849013f1da695a24e491f7e7b21a923?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							coolxenu
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Cool Xenu</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215607">
														<time datetime="2022-06-28T09:44:43-04:00" title="June 28, 2022 at 9:44 am">
								June 28, 2022 at 9:44 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>This _IS_ Alberta. The people of Sundre should embrace their ignorance and racism. The faux repudiations ring hollow after the umpteenth episode.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215607" data-postid="44796" data-belowelement="div-comment-215607" data-respondelement="respond" data-replyto="Reply to Cool Xenu" aria-label="Reply to Cool Xenu" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Cool Xenu","commentParent":"215607"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215608" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-215608" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/1f1ac0362465655ed8140b1aa2649b3b?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/1f1ac0362465655ed8140b1aa2649b3b?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/1f1ac0362465655ed8140b1aa2649b3b?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/1f1ac0362465655ed8140b1aa2649b3b?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Alan K. Spiller</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215608">
														<time datetime="2022-06-28T09:50:15-04:00" title="June 28, 2022 at 9:50 am">
								June 28, 2022 at 9:50 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>After all the years I spent living and working in rural Alberta for the Royal Bank my wife and I never thought of them as being morons who are easy to fool, yet here they are, believing every lie these Reformers feed them, ignoring what is right.  The polls continue to show that the UCPs  biggest support is in rural Alberta. The conservatives in my world are thrilled that Trudeau and Singh would join forces to hold each other accountable to the people, so what’s wrong with that?  We need this kind of government. We were also happy to see Notley and Trudeau working together for the benefit of our oil industry. After all it was our oil executives who wanted the Carbon Tax implemented and it wasn’t  Notley and  Trudeau who invented it to steal the peoples money like Kenney told them it was. Too damn  dumb to realize it’s been in place in Sweden since 1991 and hasn’t financially destroyed anyone like these Reformers claim it will.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215608" data-postid="44796" data-belowelement="div-comment-215608" data-respondelement="respond" data-replyto="Reply to Alan K. Spiller" aria-label="Reply to Alan K. Spiller" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Alan K. Spiller","commentParent":"215608"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215610" class="comment even thread-even depth-1">
			<article id="div-comment-215610" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/a09163708f7c0c906b00dc6e67656d34?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/a09163708f7c0c906b00dc6e67656d34?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/a09163708f7c0c906b00dc6e67656d34?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/a09163708f7c0c906b00dc6e67656d34?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Bob Raynard</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215610">
														<time datetime="2022-06-28T10:00:56-04:00" title="June 28, 2022 at 10:00 am">
								June 28, 2022 at 10:00 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>Under the category of ‘when you are in a hole, stop digging’, Mountain View Today might also want to disable the comments section of their report on this story.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215610" data-postid="44796" data-belowelement="div-comment-215610" data-respondelement="respond" data-replyto="Reply to Bob Raynard" aria-label="Reply to Bob Raynard" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Bob Raynard","commentParent":"215610"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215611" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-215611" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/b2edcb8bec0aea0a873c64e077888950?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/b2edcb8bec0aea0a873c64e077888950?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/b2edcb8bec0aea0a873c64e077888950?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/b2edcb8bec0aea0a873c64e077888950?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Joan Harris</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215611">
														<time datetime="2022-06-28T10:09:02-04:00" title="June 28, 2022 at 10:09 am">
								June 28, 2022 at 10:09 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>I was in one of the floats near the start. I seen that tractor and manurer spreader go east on the highway past the start about 5 minutes to 10. All of the approved entries were on the side road. That tells me it was not an approved entry but a sneak in.</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215611" data-postid="44796" data-belowelement="div-comment-215611" data-respondelement="respond" data-replyto="Reply to Joan Harris" aria-label="Reply to Joan Harris" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Joan Harris","commentParent":"215611"}}),comment.focus'>Reply</a></div>		</li>
		<li id="comment-215612" class="comment even thread-even depth-1 parent">
			<article id="div-comment-215612" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/eb03f45a056392b519fd6ec167c5a7aa?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/eb03f45a056392b519fd6ec167c5a7aa?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/eb03f45a056392b519fd6ec167c5a7aa?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/eb03f45a056392b519fd6ec167c5a7aa?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">Abs</a></b> <span class="screen-reader-text says">says:</span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215612">
														<time datetime="2022-06-28T11:02:03-04:00" title="June 28, 2022 at 11:02 am">
								June 28, 2022 at 11:02 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>Someone ought to tell those Bible-loving Sundre folks that the Bible has a new release called “The New Testament”. It’s a bestseller.</p>
<p>As for the Calgary Stetson Show Band and the Red Deer Royals, do parents of these youth want to support racists going forward? Surely there must be some visible minorities in these bands. I have seen photos from previous years that suggest there are. What does it say about the adult organizers of these groups if they decide to march in a Sundre parade ever again?</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215612" data-postid="44796" data-belowelement="div-comment-215612" data-respondelement="respond" data-replyto="Reply to Abs" aria-label="Reply to Abs" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to Abs","commentParent":"215612"}}),comment.focus'>Reply</a></div>		<ol class="children">
		<li id="comment-215613" class="comment byuser comment-author-david bypostauthor odd alt depth-2">
			<article id="div-comment-215613" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<a href="#!" rel="external nofollow" class="url">
					<figure data-amp-lightbox="true">
						<amp-img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=120&amp;d=mm&amp;r=r 2x" class="avatar avatar-60 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="60" width="60" data-amp-lightbox="" lightbox="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwIiB3aWR0aD0iNjAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=60&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=120&amp;d=mm&amp;r=r 2x" height="60" width="60" loading="lazy"></noscript></amp-img>
						<figcaption>
							davidclimenhaga
						</figcaption>
					</figure>
				<b class="fn"><a href="#!" rel="external nofollow ugc" class="url">David Climenhaga</a></b> <span class="screen-reader-text says">says:</span><span class="post-author-badge" aria-hidden="true"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 12c2.21 0 4-1.79 4-4s-1.79-4-4-4-4 1.79-4 4 1.79 4 4 4zm0 2c-2.67 0-8 1.34-8 4v2h16v-2c0-2.66-5.33-4-8-4z" /><path d="M0 0h24v24H0z" fill="none" /><title>Article author</title></svg></span></a>					</div>

					<div class="comment-metadata">
						<a href="https://albertapolitics.ca/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/#comment-215613">
														<time datetime="2022-06-28T11:06:58-04:00" title="June 28, 2022 at 11:06 am">
								June 28, 2022 at 11:06 am							</time>
						</a>
											</div>

									</footer>

				<div class="comment-content">
					<p>Abs: I think the new release has been renamed – OT2. DJC</p>
				</div>

			</article>

			<div class="comment-reply"><a rel="nofollow" class="comment-reply-link" href="#respond" data-commentid="215613" data-postid="44796" data-belowelement="div-comment-215613" data-respondelement="respond" data-replyto="Reply to David Climenhaga" aria-label="Reply to David Climenhaga" on='tap:AMP.setState({"ampCommentThreading":{"replyTo":"Reply to David Climenhaga","commentParent":"215613"}}),comment.focus'>Reply</a></div>		</li>
</ol>
</li>
			</ol>
			
		
					<div class="comment-form-flex">
				<span class="screen-reader-text">Leave a comment</span>
					<div id="respond" class="comment-respond">
		 <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/06/a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=a-thought-on-how-sundre-can-start-to-put-the-embarrassment-of-the-racist-jackassery-in-its-rodeo-parade-behind-it#respond" hidden data-amp-bind-hidden='ampCommentThreading.commentParent == "0"' on='tap:AMP.setState({ampCommentThreading: {"replyTo":"","commentParent":"0"}})' i-amphtml-binding>Cancel reply</a></small><form method="post" id="commentform" class="comment-form" novalidate target="_top" action-xhr="https://albertapolitics.ca/wp-comments-post.php?_wp_amp_action_xhr_converted=1" on='submit-success:commentform.clear,AMP.setState({ampCommentThreading: {"replyTo":"","commentParent":"0"}})'><amp-state id="ampCommentThreading" class="i-amphtml-layout-container" i-amphtml-layout="container"><script type="application/json">{"replyTo":"","commentParent":"0"}</script></amp-state><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="5" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200"></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="44796" id="comment_post_ID">
<input type="hidden" name="comment_parent" id="comment_parent" value="0" data-amp-bind-value="ampCommentThreading.commentParent" i-amphtml-binding>
</p><p data-amp-original-style="display: none;" class="amp-wp-224b51a"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="dc2b9c4e89"></p><p data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3"><label>Δ<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label></p><div class="amp-wp-default-form-message" submit-error=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}Your submission failed. <small>The server responded with {{status_text}} (code {{status_code}}). Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submit-success=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}It appears your submission was successful. <small>Even though the server responded OK, it is possible the submission was not processed. Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submitting=""><template type="amp-mustache"><p>Submitting…</p></template></div></form>	</div>
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>				<h2 class="comments-title" aria-hidden="true">Leave a comment</h2>
			</div>
			</div>
				</div>

			
<aside id="secondary" class="widget-area">
	<section id="search-4" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://albertapolitics.ca/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
</section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><div id="div-gpt-ad-62bbbf9d751f0-0"></div></div></section><section id="block-2" class="widget widget_block"><aside>					<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
			<script type="application/json">{"requests":{"event":"https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#c923","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_43547","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#c923 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_43547","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"${formFields[email]}"}}}}</script>
		</amp-analytics>
					<amp-layout amp-access="popups.id_43547" amp-access-hide class="newspack-popup  newspack-inline-popup  newspack-lightbox-has-title  newspack-newsletter-prompt-inline amp-wp-85c1a93 i-amphtml-layout-container" role="button" tabindex="0" id="c923" data-amp-original-style="background-color:#FFFFFF;color:#000" i-amphtml-layout="container">
									<h1 class="newspack-popup-title">Get the latest from Alberta Politics</h1>
								
<p>Join our mailing list to receive the latest updates from Alberta Politics.</p>


<amp-layout id="n8b2" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="81805484">
		<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/81805484/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
			<p>
				<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
			</p>
									
<div class="wp-block-jetpack-button wp-block-button"><button class="wp-block-button__link" data-id-attr="mailchimp-button-block-3" id="mailchimp-button-block-3" type="submit">Sign Up</button></div>
			<p id="wp-block-jetpack-mailchimp_consent-text">
				By clicking submit, you agree to share your email address with the site owner to receive the latest Alberta Politics in your inbox. Use the unsubscribe link in those emails to opt out at any time.			</p>

			
				<div submit-success>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
							Success! You're on the list.						</div>
					</template>
				</div>
				<div submit-error>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
							Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.						</div>
					</template>
				</div>
				<div submitting>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
							Processing…						</div>
					</template>
				</div>

			
		</form>
			</div>
	</amp-layout>


<p></p>
												<form class="popup-not-interested-form c9231 popup-action-form c923 align-center" method="POST" action-xhr="https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
							<input name="popup_id" type="hidden" value="id_43547">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status" i-amphtml-binding>
		<input name="is_newsletter_popup" type="hidden" value="1">
						<input name="suppress_forever" type="hidden" value="1">
				<button on="tap:c923.hide" aria-label="" data-amp-original-style="background-color:#FFFFFF;color:#000" class="amp-wp-85c1a93">I'm not interested</button>
			</form>
									</amp-layout>
		</aside></section></aside>

		</main>
	</section>


	
			<div class="newspack_global_ad global_above_footer">
						<div id="div-gpt-ad-2817889af1-0"></div>		</div>
				<div class="newspack_global_ad sticky">
							<button class="newspack_sticky_ad__close"></button>
						<div id="div-gpt-ad-7df62cd581-0"></div>		</div>
		
	</div>

	<footer id="colophon" class="site-footer">

						
		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2022 David J. Climenhaga.</span>
				
				<a target="_blank" href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div>
		</div>
	</footer>

</div>

		<script data-amp-plus-allowed data-amp-unvalidated-tag>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</script>
					<amp-analytics type="gtag" config="https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=44796&amp;custom_dimensions=[]&amp;custom_dimensions_existing_values=[]" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-analytics>
			<div data-amp-original-style="display:none" class="amp-wp-cb45893">
			<div class="grofile-hash-map-9acc1f4feb640dc310e08ee0449bb4b0">
		</div>
		</div>
				<amp-install-serviceworker src="https://albertapolitics.ca/wp.serviceworker" data-iframe-src="https://albertapolitics.ca/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		

<script data-amp-plus-allowed async src="https://albertapolitics.ca/wp-content/themes/newspack-theme/js/dist/amp-plus.js?ver=1.56.2" data-amp-unvalidated-tag></script>




			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
				<script type="application/json">{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}</script>
			</amp-analytics>
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A11.0&amp;blog=81805484&amp;post=44796&amp;tz=-4&amp;srv=albertapolitics.ca&amp;host=albertapolitics.ca&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
