<!DOCTYPE html>
<html lang="en-CA" transformed="self;v=1" i-amphtml-layout="" i-amphtml-no-boilerplate="" i-amphtml-binding>
<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012204221712000">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</style><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Will students learn ‘financial literacy’ or corporate propaganda from Alberta’s $5M curriculum ‘investment’?  - Alberta Politics"><meta property="og:description" content="There’s nothing wrong with a little financial education, but is that what Alberta students will be getting from the grade school “financial literacy” program Alberta Education Minister Adriana LaGrange announced so enthusiastically yesterday?"><meta property="og:url" content="https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/"><meta property="og:site_name" content="Alberta Politics"><meta property="article:author" content="https://www.facebook.com/david.climenhaga.7"><meta property="article:published_time" content="2022-05-06T06:23:28+00:00"><meta property="article:modified_time" content="2022-05-06T06:23:29+00:00"><meta property="og:image" content="https://albertapolitics.ca/wp-content/uploads/LaGrange-13.png"><meta property="og:image:width" content="1196"><meta property="og:image:height" content="785"><meta property="og:image:type" content="image/png"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="David Climenhaga"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="5 minutes"><meta name="generator" content="WordPress 5.9.3"><meta name="generator" content="Site Kit by Google 1.73.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-title" content="Alberta Politics"><meta name="application-name" content="Alberta Politics"><meta name="generator" content="AMP Plugin v2.2.4; mode=standard"><meta name="msapplication-TileImage" content="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=270%2C270&amp;ssl=1"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//v0.wordpress.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="preload" href="https://albertapolitics.ca/wp-content/plugins/jetpack/_inc/social-logos/social-logos.eot?5d3b4da4f6c2460dd842dbf9e0992ea6#iefix" as="font" crossorigin=""><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin=""><link rel="dns-prefetch" href="https://fonts.gstatic.com"><script type="module" src="https://cdn.ampproject.org/v0.mjs" id="amp-runtime-js" async crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0.js" crossorigin="anonymous"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-access-0.1.mjs" id="amp-access-js" async custom-element="amp-access" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-access-0.1.js" crossorigin="anonymous" custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.mjs" async="" custom-element="amp-analytics" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" crossorigin="anonymous" custom-element="amp-analytics"></script><script type="module" src="https://cdn.ampproject.org/v0/amp-bind-0.1.mjs" id="amp-bind-js" async custom-element="amp-bind" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" crossorigin="anonymous" custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.mjs" async="" custom-element="amp-form" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-form-0.1.js" crossorigin="anonymous" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.mjs" async="" custom-element="amp-install-serviceworker" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" crossorigin="anonymous" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.mjs" async="" custom-template="amp-mustache" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" crossorigin="anonymous" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.mjs" async="" custom-element="amp-sidebar" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" crossorigin="anonymous" custom-element="amp-sidebar"></script><link rel="icon" href="https://albertapolitics.ca/wp-content/uploads/cropped-abpoli-150x150.png" sizes="32x32"><link rel="icon" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="canonical" href="https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://albertapolitics.ca/#website","url":"https://albertapolitics.ca/","name":"Alberta Politics","description":"David Climenhaga\u0026#039;s Alberta Politics Blog","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://albertapolitics.ca/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","inLanguage":"en-CA","@id":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/#primaryimage","url":"https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?fit=1196%2C785\u0026ssl=1","contentUrl":"https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?fit=1196%2C785\u0026ssl=1","width":1196,"height":785,"caption":"Alberta Education Minister Adriana LaGrange at yesterday\u2019s news conference (Photo: Screenshot of Alberta Government video)."},{"@type":"WebPage","@id":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/#webpage","url":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/","name":"Will students learn \u2018financial literacy\u2019 or corporate propaganda from Alberta\u2019s $5M curriculum \u2018investment\u2019?\u00a0 - Alberta Politics","isPartOf":{"@id":"https://albertapolitics.ca/#website"},"primaryImageOfPage":{"@id":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/#primaryimage"},"datePublished":"2022-05-06T06:23:28+00:00","dateModified":"2022-05-06T06:23:29+00:00","author":{"@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779"},"breadcrumb":{"@id":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/"]}]},{"@type":"BreadcrumbList","@id":"https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://albertapolitics.ca/"},{"@type":"ListItem","position":2,"name":"All News","item":"https://albertapolitics.ca/top-news/"},{"@type":"ListItem","position":3,"name":"Will students learn \u2018financial literacy\u2019 or corporate propaganda from Alberta\u2019s $5M curriculum \u2018investment\u2019?\u00a0"}]},{"@type":"Person","@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779","name":"David Climenhaga","image":{"@type":"ImageObject","inLanguage":"en-CA","@id":"https://albertapolitics.ca/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96\u0026d=mm\u0026r=r","contentUrl":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96\u0026d=mm\u0026r=r","caption":"David Climenhaga"},"sameAs":["https://www.facebook.com/david.climenhaga.7","https://twitter.com/djclimenhaga"],"url":"https://albertapolitics.ca/author/david/"}]}</script><link rel="alternate" type="application/rss+xml" title="Alberta Politics » Feed" href="https://albertapolitics.ca/feed/"><link rel="alternate" type="application/rss+xml" title="Alberta Politics » Comments Feed" href="https://albertapolitics.ca/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Alberta Politics » Will students learn ‘financial literacy’ or corporate propaganda from Alberta’s $5M curriculum ‘investment’?  Comments Feed" href="https://albertapolitics.ca/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/feed/"><link rel="https://api.w.org/" href="https://albertapolitics.ca/wp-json/"><link rel="alternate" type="application/json" href="https://albertapolitics.ca/wp-json/wp/v2/posts/44043"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://albertapolitics.ca/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://albertapolitics.ca/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/p5xfli-bsn"><link rel="alternate" type="application/json+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F05%2Fwill-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment%2F"><link rel="alternate" type="text/xml+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F05%2Fwill-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment%2F&amp;format=xml"><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" data-amp-plus-allowed data-amp-unvalidated-tag></script><script id="amp-access" type="application/json">{"namespace":"popups","authorization":"https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php?cid=CLIENT_ID(newspack-cid)\u0026ref=DOCUMENT_REFERRER\u0026popups=[{\"id\":\"id_43547\",\"f\":\"once\",\"utm\":null,\"s\":\"\",\"n\":true,\"d\":false,\"t\":\"i\",\"c\":\"custom1\"}]\u0026settings={\"active\":null,\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_donor_landing_page\":\"\",\"newspack_popups_mc_donor_merge_field\":\"DONAT\",\"newspack_popups_non_interative_mode\":false,\"all_segments\":{\"624a724f4180e\":{\"min_posts\":\"5\",\"max_posts\":0,\"min_session_posts\":0,\"max_session_posts\":0,\"is_subscribed\":false,\"is_donor\":false,\"is_not_subscribed\":false,\"is_not_donor\":true,\"favorite_categories\":[],\"referrers\":\"\",\"referrers_not\":\"\",\"priority\":0}},\"newspack_popups_active_campaign_group\":false}\u0026visit={\"post_id\":\"44043\",\"categories\":\"396\",\"is_post\":true}","noPingback":true}</script><link rel="manifest" href="https://albertapolitics.ca/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=192%2C192&amp;ssl=1"><link rel="pingback" href="https://albertapolitics.ca/xmlrpc.php"><link rel="apple-touch-icon" href="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/cropped-abpoli.png?fit=180%2C180&amp;ssl=1"><title>Will students learn ‘financial literacy’ or corporate propaganda from Alberta’s $5M curriculum ‘investment’?  - Alberta Politics</title></head>

<body class="post-template-default single single-post postid-44043 single-format-standard wp-custom-logo wp-embed-responsive singular hide-site-tagline h-nsub h-db h-ll h-dh h-stk has-tertiary-menu has-sidebar cat-alberta-politics-2 has-featured-image single-featured-image-default" data-amp-auto-lightbox-disable>
<svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-dark-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0.49803921568627"></fefuncr><fefuncg type="table" tablevalues="0 0.49803921568627"></fefuncg><fefuncb type="table" tablevalues="0 0.49803921568627"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-grayscale"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.54901960784314 0.98823529411765"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.71764705882353 0.25490196078431"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-red"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 1"></fefuncr><fefuncg type="table" tablevalues="0 0.27843137254902"></fefuncg><fefuncb type="table" tablevalues="0.5921568627451 0.27843137254902"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-midnight"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0 0"></fefuncr><fefuncg type="table" tablevalues="0 0.64705882352941"></fefuncg><fefuncb type="table" tablevalues="0 1"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-magenta-yellow"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.78039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.94901960784314"></fefuncg><fefuncb type="table" tablevalues="0.35294117647059 0.47058823529412"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-purple-green"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.65098039215686 0.40392156862745"></fefuncr><fefuncg type="table" tablevalues="0 1"></fefuncg><fefuncb type="table" tablevalues="0.44705882352941 0.4"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 0 0" width="0" height="0" focusable="false" role="none" data-amp-original-style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" class="amp-wp-bf126db"><defs><filter id="wp-duotone-blue-orange"><fecolormatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></fecolormatrix><fecomponenttransfer color-interpolation-filters="sRGB"><fefuncr type="table" tablevalues="0.098039215686275 1"></fefuncr><fefuncg type="table" tablevalues="0 0.66274509803922"></fefuncg><fefuncb type="table" tablevalues="0.84705882352941 0.41960784313725"></fefuncb><fefunca type="table" tablevalues="1 1"></fefunca></fecomponenttransfer><fecomposite in2="SourceGraphic" operator="in"></fecomposite></filter></defs></svg>		<div class="newspack_global_ad global_above_header">
						<div id="div-gpt-ad-d23a71ee67-0"></div>		</div>
			<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>

				<nav class="tertiary-menu nav3" aria-label="Tertiary Menu" toolbar-target="tertiary-nav-contain" toolbar="(min-width: 767px)">
			<ul id="menu-support" class="menu"><li id="menu-item-43562" class="menu-highlight menu-item menu-item-type-post_type menu-item-object-page menu-item-43562"><a href="https://albertapolitics.ca/donate/">Support Us</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://albertapolitics.ca/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
<section id="nav_menu-3" class="below-content widget widget_nav_menu"><h2 class="widget-title">Menu</h2><div class="menu-top-nav-container"><ul id="menu-top-nav" class="menu"><li id="menu-item-15918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-15918"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-15929" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-15929"><a href="https://albertapolitics.ca/top-news/" aria-haspopup="true" aria-expanded="false">All News</a>
<ul class="sub-menu">
	<li id="menu-item-43524" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43524"><a href="https://albertapolitics.ca/category/alberta-politics-2/">Alberta Politics</a></li>
	<li id="menu-item-43525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43525"><a href="https://albertapolitics.ca/category/canadian-politics/">Canadian Politics</a></li>
	<li id="menu-item-43526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43526"><a href="https://albertapolitics.ca/category/geopolitics/">Geopolitics</a></li>
	<li id="menu-item-43527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43527"><a href="https://albertapolitics.ca/category/st-albert/">St. Albert</a></li>
	<li id="menu-item-43528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43528"><a href="https://albertapolitics.ca/category/bestsellers/">Bestsellers</a></li>
	<li id="menu-item-43529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43529"><a href="https://albertapolitics.ca/category/guest-posts/">Guest Posts</a></li>
</ul>
</li>
<li id="menu-item-15936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15936"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26057"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li id="menu-item-32647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32647"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
<li id="menu-item-42009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42009"><a href="https://albertapolitics.ca/subscribe-to-newsletter/">Subscribe to Newsletter</a></li>
</ul></div></section>
	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill="none" /></svg>			Close		</button>
<section id="nav_menu-3" class="below-content widget widget_nav_menu"><h2 class="widget-title">Menu</h2><div class="menu-top-nav-container"><ul id="menu-top-nav-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-15918"><a href="https://albertapolitics.ca/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-15929"><a href="https://albertapolitics.ca/top-news/" aria-haspopup="true" aria-expanded="false">All News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43524"><a href="https://albertapolitics.ca/category/alberta-politics-2/">Alberta Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43525"><a href="https://albertapolitics.ca/category/canadian-politics/">Canadian Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43526"><a href="https://albertapolitics.ca/category/geopolitics/">Geopolitics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43527"><a href="https://albertapolitics.ca/category/st-albert/">St. Albert</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43528"><a href="https://albertapolitics.ca/category/bestsellers/">Bestsellers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43529"><a href="https://albertapolitics.ca/category/guest-posts/">Guest Posts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15936"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26057"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32647"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42009"><a href="https://albertapolitics.ca/subscribe-to-newsletter/">Subscribe to Newsletter</a></li>
</ul></div></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'" i-amphtml-binding>

					
			<div class="middle-header-contain">
				<div class="wrapper">
											<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none" /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg>							<span>Menu</span>
						</button>
					
					
					
					<div class="site-branding">

	
		<a href="https://albertapolitics.ca/" class="custom-logo-link" rel="home"><amp-img noloading="" width="886" height="220" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?fit=886%2C220&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Alberta Politics" data-hero-candidate="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?w=886&amp;ssl=1 886w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=600%2C149&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=400%2C99&amp;ssl=1 400w" sizes="(max-width: 886px) 100vw, 886px" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIyMCIgd2lkdGg9Ijg4NiIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="Alberta Politics" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?fit=886%2C220&amp;ssl=1" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?w=886&amp;ssl=1 886w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=600%2C149&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/2014/12/AlbertaPoliticsLogo.png?resize=400%2C99&amp;ssl=1 400w" sizes="(max-width: 886px) 100vw, 886px"></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://albertapolitics.ca/" rel="home">Alberta Politics</a></p>
					
						<p class="site-description">
					David Climenhaga's Alberta Politics Blog				</p>
			</div>

</div>

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div>

											</div>

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none" /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg>							<span>Menu</span>
						</button>
					
				</div>
			</div>


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

											</div>
				</div>
					
					<div class="sticky-bg"></div>
			</header>

	
	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-alberta-politics-2 tag-adriana-lagrange tag-alberta-politics tag-alberta-teachers-association tag-education tag-jason-schilling tag-literacy-education">
		<main id="main" class="site-main">

								<header class="entry-header">
						
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://albertapolitics.ca/category/alberta-politics-2/" rel="category tag">Alberta Politics</a></span>			<h1 class="entry-title ">
			Will students learn ‘financial literacy’ or corporate propaganda from Alberta’s $5M curriculum ‘investment’? 		</h1>
		
	<div class="entry-subhead">
									<div class="entry-meta">
					<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=192&amp;d=mm&amp;r=r 2x" class="avatar avatar-96 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="96" width="96" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijk2IiB3aWR0aD0iOTYiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&amp;d=mm&amp;r=r" srcset="https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=192&amp;d=mm&amp;r=r 2x" height="96" width="96" loading="lazy"></noscript></amp-img></span><span class="byline"><span>by</span> <span class="author vcard"><a class="url fn n" href="https://albertapolitics.ca/author/david/">David Climenhaga</a></span></span><span class="posted-on"><time class="entry-date published" datetime="2022-05-06T02:23:28-04:00">May 6, 2022</time><time class="updated" datetime="2022-05-06T02:23:29-04:00">May 6, 2022</time></span>				</div>
								</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="1196" height="785" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?fit=1196%2C785&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?w=1196&amp;ssl=1 1196w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=600%2C394&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=1024%2C672&amp;ssl=1 1024w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=400%2C263&amp;ssl=1 400w" sizes="(max-width: 1196px) 100vw, 1196px" data-hero-candidate="" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9Ijc4NSIgd2lkdGg9IjExOTYiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?fit=1196%2C785&amp;ssl=1" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?w=1196&amp;ssl=1 1196w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=600%2C394&amp;ssl=1 600w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=1024%2C672&amp;ssl=1 1024w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/LaGrange-13.png?resize=400%2C263&amp;ssl=1 400w" sizes="(max-width: 1196px) 100vw, 1196px"></amp-img>			<figcaption><span>Alberta Education Minister Adriana LaGrange at yesterday’s news conference (Photo: Screenshot of Alberta Government video). </span></figcaption>
			
			</figure>

		

<article id="post-44043" class="post-44043 post type-post status-publish format-standard has-post-thumbnail hentry category-alberta-politics-2 tag-adriana-lagrange tag-alberta-politics tag-alberta-teachers-association tag-education tag-jason-schilling tag-literacy-education entry">
	<div class="entry-content">

		
		
<p>There’s nothing wrong with a little financial education, but is that what Alberta students will be getting from the grade school “financial literacy” program Alberta Education Minister Adriana LaGrange announced at <a href="https://www.youtube.com/watch?v=uJiGSt02uN8&amp;list=PLvrD8tiHIX1L0ztJVj7n2YM7L6Ai5tp0s&amp;t=3s">a news conference</a> yesterday?</p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="250" height="334" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?resize=250%2C334&amp;ssl=1" alt="" class="wp-image-44049 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?w=250&amp;ssl=1 250w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?resize=150%2C200&amp;ssl=1 150w" sizes="(max-width: 250px) 100vw, 250px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjMzNCIgd2lkdGg9IjI1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="250" height="334" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?resize=250%2C334&amp;ssl=1" alt="" srcset="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?w=250&amp;ssl=1 250w, https://i0.wp.com/albertapolitics.ca/wp-content/uploads/Schilling-8.jpeg?resize=150%2C200&amp;ssl=1 150w" sizes="(max-width: 250px) 100vw, 250px"></noscript></amp-img><figcaption>Alberta Teachers Association President Jason Schilling (Photo: David J. Climenhaga). </figcaption></figure></div>



<p>Ms. LaGrange said the United Conservative Party Government will pour $5 million into three organizations to provide what <a href="https://www.alberta.ca/release.cfm?xID=82506D3BA0929-C6AD-E3CE-3FCCA9FE34C2FD06">her potted quote in the government’s news release</a> called “future entrepreneurs, innovators and creators” with “much-needed financial knowledge and skills for personal and professional success.”</p>



<p>I don’t know about you, but when I hear this kind of expenditure of public funds described as an “investment” it sets my nose twitching for the source of the stuff sprayed on the fields just west of my little house on the Prairie. </p>



<p>So who or what are these organizations that will supposedly be providing financial literacy “learnings” for Alberta students? </p>



<p>Something called the Enriched Academy will receive $900,000 per year over the next three years to “provide students in grades 7 to 12 with financial literacy programming on topics such as money management, budgeting, credit and student loans.”</p>
<aside class="scaip scaip-1    "><aside id="newspack-ads-widget-2" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-ad-627503bb80172-0"></div></div></aside></aside>



<p>Enriched Academy, seemingly sometimes presented as <em>EnRICHed</em> Academy, appears to be a private company, not an <em>academy</em>, that sells pre-packaged courses about money. <a href="https://www.enrichedacademy.com/">Its website</a> is remarkably uninformative. There is very little information about it from neutral sources. Nor is the government’s news release particularly helpful. </p>



<div class="wp-block-image"><figure class="alignright size-full"><amp-img width="250" height="360" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/FDR-1.jpg?resize=250%2C360&amp;ssl=1" alt="" class="wp-image-44048 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer slot="i-amphtml-svc" class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjM2MCIgd2lkdGg9IjI1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="250" height="360" src="https://i0.wp.com/albertapolitics.ca/wp-content/uploads/FDR-1.jpg?resize=250%2C360&amp;ssl=1" alt=""></noscript></amp-img><figcaption>The late U.S. President Franklin D. Roosevelt, who doesn’t have that much to do with this story, but sure took a good picture. (Photo: FDR Presidential Library and Museum). </figcaption></figure></div>



<p>A non-profit organization called the Canadian Foundation for Economic Education will be given $500,000 a year for the same stated purpose. Like the academy, little balanced information from neutral sources appears to be immediately accessible about the CFEE.</p>



<p>However, it appears to be somewhat more transparent. There seem to be lots of people connected to the financial services industry on its board and staff. There are a few with ties to both the federal Liberal and Conservatives parties. Union officials? I didn’t notice any. </p>



<p>Who bankrolls it – other than Alberta taxpayers now – is not immediately clear. Banks and financial services companies certainly play a role, <a href="https://cfee.org/">judging from its website</a>. Perhaps this can be cleared up in the days ahead. </p>



<p>The CFEE, fortunately, does not seem to be associated with the Foundation for Economic Education, the libertarian U.S. think tank founded in 1947 in hopes of rolling back the policies of President Franklin D. Roosevelt’s New Deal. Still, I don’t imagine the CFEE will be teaching Alberta students about the benefits to Canada of a Green New Deal or a Just Transition any time soon.</p>
<aside class="scaip scaip-2    "><aside id="newspack-ads-widget-3" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-ad-627503bb804bb-0"></div></div></aside></aside>



<p>Finally, <a href="https://jasab.ca/">Junior Achievement Southern Alberta</a> will receive $250,000 a year for three years to “provide young learners in grades 3 to 6 with hands-on, experiential financial literacy programming, work readiness and entrepreneurship education.”</p>



<p>These are also phrases that should set alarm bells ringing among <em>financially literate</em> people who pay attention to the activities of right-wing governments. </p>



<p>Unlike the other two, JA has <a href="https://en.wikipedia.org/wiki/Junior_Achievement">a Wikipedia page</a>. Unfortunately, according to the folks who run the Wikipedia, the article about the international organization of that name “contains content that is written like an advertisement,”or may even “have been created or edited in return for undisclosed payments.”</p>



<p>We do know, though, that JA Worldwide was <a href="https://www.researchgate.net/publication/248975266_Putting_school_commercialism_in_context_A_global_history_of_Junior_Achievement_Worldwide">a key part of a fightback effort by the U.S. National Association of Managers in the 1940s to counter the legacy of the New Deal</a> and inculcate young people with enthusiasm for corporate capitalism.</p>



<p>To its credit, JA Southern Alberta is transparent about its mostly corporate donors – who, <a href="https://jasab.ca/donors/our-donors.html">according to its website</a>, are its only source of revenue. Which makes all of us Albertans, I guess, JA donors too, double-donors if you happen to live in Chestermere, Nanton, Kneehill County, Cochrane, Strathmore or a few other Alberta communities. </p>



<p>The three organizations will reach more than 360,000 students with their program, the government press release boasts. </p>



<p>The release doesn’t say if the curriculum materials developed by the three organizations will be properly vetted by curriculum professionals for accuracy and balance. But then, as we have seen with the government’s controversial and highly ideological K-6 curriculum changes, the UCP doesn’t pay much attention to curriculum professionals anyway. </p>



<p>Will Albertans be getting good value for this “investment”? It’s too soon to say. </p>



<p>Will Alberta students be getting genuine financial literacy tools or corporate propaganda? Probably a bit of both.</p>



<p>What will they be told about Bitcoin and other cryptocurrencies, if anything? God only knows. </p>



<p>And since, according to the UCP Government, parents know best how their children should be educated, will parents have the option of pulling their children out of these programs if they find them to be biased and propagandistic? Don’t count on it. </p>



<p><strong>ATA assails Bill 15 as ‘profoundly damaging’</strong></p>



<p>While <a href="https://twitter.com/AdrianaLaGrange/status/1522029549239775232">Ms. LaGrange trilled Wednesday</a> about how pleased she was by the passage of Bill 15, legislation that strips the Alberta Teachers Association of its regulatory role and hands it to a government appointee, ATA President Jason Schilling yesterday said the change “will be profoundly damaging to one of the world’s best education systems.”</p>



<p>“Albertans should be very concerned that this bill was passed based on unfounded allegations propelled by lies and misinformation,” <a href="https://www.teachers.ab.ca/News%20Room/NewsReleases/Pages/Statement-on-Bill-15-Passage.aspx">Mr. Schilling said bluntly in a news release</a>. </p>



<p>“Bill 15 is an effort to punish the association and teachers for daring to stand up to the government’s bad decisions when it comes to education, and to coerce us into complying with their agenda, but we will not waver,” he said. “We will continue today and into the future to stand up for students, for teachers and for public education.”</p>
<section id="newspack-ads-widget-4" class="below-content widget widget_newspack-ads-widget"><div class="textwidget"><div id="div-gpt-ad-627503bb80df3-0"></div></div></section>	</div>

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://albertapolitics.ca/tag/adriana-lagrange/" rel="tag">Adriana LaGrange</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/alberta-politics/" rel="tag">Alberta politics</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/alberta-teachers-association/" rel="tag">Alberta Teachers Association</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/education/" rel="tag">Education</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/jason-schilling/" rel="tag">Jason Schilling</a><span class="sep">, </span><a href="https://albertapolitics.ca/tag/literacy-education/" rel="tag">Literacy Education</a></span>	</footer>

	
</article>

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2>
			</div>
			<div id="respond" class="comment-respond">
		 <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=will-students-learn-financial-literacy-or-corporate-propaganda-from-albertas-5m-curriculum-investment#respond" hidden data-amp-bind-hidden='ampCommentThreading.commentParent == "0"' on='tap:AMP.setState({ampCommentThreading: {"replyTo":"","commentParent":"0"}})' i-amphtml-binding>Cancel reply</a></small><form method="post" id="commentform" class="comment-form" novalidate target="_top" action-xhr="https://albertapolitics.ca/wp-comments-post.php?_wp_amp_action_xhr_converted=1" on='submit-success:commentform.clear,AMP.setState({ampCommentThreading: {"replyTo":"","commentParent":"0"}})'><amp-state id="ampCommentThreading" class="i-amphtml-layout-container" i-amphtml-layout="container"><script type="application/json">{"replyTo":"","commentParent":"0"}</script></amp-state><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="5" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200"></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="44043" id="comment_post_ID">
<input type="hidden" name="comment_parent" id="comment_parent" value="0" data-amp-bind-value="ampCommentThreading.commentParent" i-amphtml-binding>
</p><p data-amp-original-style="display: none;" class="amp-wp-224b51a"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4da1b3e00e"></p><p data-amp-original-style="display: none !important;" class="amp-wp-3e2e7c3"><label>Δ<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label></p><div class="amp-wp-default-form-message" submit-error=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}Your submission failed. <small>The server responded with {{status_text}} (code {{status_code}}). Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submit-success=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}It appears your submission was successful. <small>Even though the server responded OK, it is possible the submission was not processed. Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank" rel="nofollow noreferrer noopener">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submitting=""><template type="amp-mustache"><p>Submitting…</p></template></div></form>	</div>
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
				</div>

			
<aside id="secondary" class="widget-area">
	<section id="search-4" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://albertapolitics.ca/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill="none" /></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
</section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><div id="div-gpt-ad-627503bb8228a-0"></div></div></section><section id="block-2" class="widget widget_block"><aside>					<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
			<script type="application/json">{"requests":{"event":"https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php"},"triggers":{"trackPageview":{"on":"visible","request":"event","visibilitySpec":{"selector":"#c838","visiblePercentageMin":90,"totalTimeMin":500,"continuousTimeMin":200},"extraUrlParams":{"popup_id":"id_43547","cid":"CLIENT_ID(newspack-cid)"}},"formSubmitSuccess":{"on":"amp-form-submit-success","request":"event","selector":"#c838 .wp-block-jetpack-mailchimp form","extraUrlParams":{"popup_id":"id_43547","cid":"CLIENT_ID(newspack-cid)","mailing_list_status":"subscribed","email":"${formFields[email]}"}}}}</script>
		</amp-analytics>
					<amp-layout amp-access="popups.id_43547" amp-access-hide class="newspack-popup  newspack-inline-popup  newspack-lightbox-has-title  newspack-newsletter-prompt-inline amp-wp-85c1a93 i-amphtml-layout-container" role="button" tabindex="0" id="c838" data-amp-original-style="background-color:#FFFFFF;color:#000" i-amphtml-layout="container">
									<h1 class="newspack-popup-title">Get the latest from Alberta Politics</h1>
								
<p>Join our mailing list to receive the latest updates from Alberta Politics.</p>


<amp-layout id="n7c3" class="i-amphtml-layout-container" i-amphtml-layout="container">
	<div class="wp-block-jetpack-mailchimp" data-blog-id="81805484">
		<form aria-describedby="wp-block-jetpack-mailchimp_consent-text" action-xhr="https://public-api.wordpress.com/rest/v1.1/sites/81805484/email_follow/amp/subscribe/" method="post" id="mailchimp_form" target="_top" on="submit-success:AMP.setState( { mailing_list_status: 'subscribed', mailing_list_email: event.response.email } )">
			<p>
				<input aria-label="Enter your email" placeholder="Enter your email" required title="Enter your email" type="email" name="email">
			</p>
									
<div class="wp-block-jetpack-button wp-block-button"><button class="wp-block-button__link" data-id-attr="mailchimp-button-block-3" id="mailchimp-button-block-3" type="submit">Sign Up</button></div>
			<p id="wp-block-jetpack-mailchimp_consent-text">
				By clicking submit, you agree to share your email address with the site owner to receive the latest Alberta Politics in your inbox. Use the unsubscribe link in those emails to opt out at any time.			</p>

			
				<div submit-success>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_success wp-block-jetpack-mailchimp__is-amp">
							Success! You're on the list.						</div>
					</template>
				</div>
				<div submit-error>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_error wp-block-jetpack-mailchimp__is-amp">
							Whoops! There was an error and we couldn't process your subscription. Please reload the page and try again.						</div>
					</template>
				</div>
				<div submitting>
					<template type="amp-mustache">
						<div class="wp-block-jetpack-mailchimp_notification wp-block-jetpack-mailchimp_processing wp-block-jetpack-mailchimp__is-amp" role="status">
							Processing…						</div>
					</template>
				</div>

			
		</form>
			</div>
	</amp-layout>


<p></p>
												<form class="popup-not-interested-form c8381 popup-action-form c838 align-center" method="POST" action-xhr="https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/campaigns/index.php" target="_top">
							<input name="popup_id" type="hidden" value="id_43547">
		<input name="cid" type="hidden" value="CLIENT_ID(newspack-cid)" data-amp-replace="CLIENT_ID">
		<input name="mailing_list_status" type="hidden" data-amp-bind-value="mailing_list_status" i-amphtml-binding>
		<input name="is_newsletter_popup" type="hidden" value="1">
						<input name="suppress_forever" type="hidden" value="1">
				<button on="tap:c838.hide" aria-label="" data-amp-original-style="background-color:#FFFFFF;color:#000" class="amp-wp-85c1a93">I'm not interested</button>
			</form>
									</amp-layout>
		</aside></section></aside>

		</main>
	</section>


	
			<div class="newspack_global_ad global_above_footer">
						<div id="div-gpt-ad-2817889af1-0"></div>		</div>
				<div class="newspack_global_ad sticky">
							<button class="newspack_sticky_ad__close"></button>
						<div id="div-gpt-ad-7df62cd581-0"></div>		</div>
		
	</div>

	<footer id="colophon" class="site-footer">

						
		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2022 David J. Climenhaga.</span>
				
				<a target="_blank" href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div>
		</div>
	</footer>

</div>

		<script data-amp-plus-allowed data-amp-unvalidated-tag>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</script>
					<amp-analytics type="gtag" config="https://albertapolitics.ca/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=44043&amp;custom_dimensions=[]&amp;custom_dimensions_existing_values=[]" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-analytics>
			<div data-amp-original-style="display:none" class="amp-wp-cb45893">
			<div class="grofile-hash-map-9acc1f4feb640dc310e08ee0449bb4b0">
		</div>
		</div>
				<amp-install-serviceworker src="https://albertapolitics.ca/wp.serviceworker" data-iframe-src="https://albertapolitics.ca/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		

<script data-amp-plus-allowed async src="https://albertapolitics.ca/wp-content/themes/newspack-theme/js/dist/amp-plus.js?ver=1.56.2" data-amp-unvalidated-tag></script>




			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
				<script type="application/json">{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}</script>
			</amp-analytics>
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A10.9&amp;blog=81805484&amp;post=44043&amp;tz=-4&amp;srv=albertapolitics.ca&amp;host=albertapolitics.ca&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
