<!doctype html>
<!--[if lt IE 7]><html lang="en-CA" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-CA" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-CA" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-CA" class="no-js"><!--<![endif]-->
<head>
<meta charset="UTF-8">
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<![endif]-->
<!-- mobile meta (hooray!) -->
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<link rel="shortcut icon" href="						" />
<meta name="msapplication-TileColor" content="#f01d4f">
<link rel="pingback" href="https://albertapolitics.ca/xmlrpc.php">
<script>var et_site_url='https://albertapolitics.ca';var et_post_id='42051';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up! - Alberta Politics</title>
	<link rel="canonical" href="https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up! - Alberta Politics" />
	<meta property="og:description" content="Jason Kenney held a news conference about nothing yesterday. Alberta’s premier said he’s “very determined” there will be no additional delays and schools will reopen as planned on Monday, the continued rapid spread of the Omicron variant of COVID-19 notwithstanding. It doesn’t sound as if much has been done to make schools safer, so teachers will just have to suck it up. Unlike other jurisdictions, no additional measures to control transmission of the virus will be implemented. So hard-pressed health care workers will have to suck it up too. Mr. Kenney urged Albertans as he habitually does to behave responsibly, get their boosters, reduce their social contacts, and take a rapid test if they can find one. We’ll all need to suck it up. And while he said he’ll be meeting his COVID Cabinet Committee today, there was no indication any decisions will be made or new policies implemented by the United Conservative Party Government. So, not nothing, exactly. Just the same old, same old. If you were thinking of a certain TV sitcom often described as a show about nothing, the effect was similar, but not identical. No comic genius like Larry David is plotting clever dialogue behind the scenes. There is no jangly music between the premier’s meaningless responses to reporters’ non sequiturs. The only time Mr. Kenney showed much animation yesterday was when he pivoted in response to a journalist’s question to crossly blame Calgary City Council for the breakdown in negotiations with a group of penny-pinching billionaires to build a new arena for the Calgary Flames with public money. (Ken King must be spinning like a top in the Flames section of paradise!) Still, things are happening because nothing is happening. For example, last Friday pregnancy services were temporarily shut down at the Fort Saskatchewan Community Hospital because too many staff were off sick with COVID. The facility has since reopened, but it’s probably not the last time something like that will happen at an Alberta health care facility in the near future. But there’s nothing you can do about that either. So the effect is alarming, not amusing. Mr. Kenney and his cabinet have taken the same approach to the pandemic, in other words, as Alberta governments have traditionally taken to low fossil fuel resource prices: they’re praying for things to improve. They pray for higher oil prices so that they can declare their stewardship a financial success; for lower hospitalizations because of Omicron’s presumed reduced lethality so that they can declare their crisis management an epidemiological triumph. In other words, as was once said, unfairly, of Progressive Conservative premier Ed Stelmach: No plan … no plan …  Why schedule a news conference when there’s so little to say that the government can’t even be bothered to compose a news release? (And who ever heard of that?) Well, I suppose Mr. Kenney needs to demonstrate to Albertans that notwithstanding his plummeting approval rate and all the talk of rebels in his caucus he’s still the premier, still in charge. And Chief Medical Officer of Health Deena Hinshaw, who co-starred with him in yesterday’s unfunny episode of Kenney, is needed to read out the grim statistics. COVID cases are breaking records again, she said. There are 34,276 known active cases in the province now, although there are probably many more.  There were nearly 13,000 new cases reported between Dec. 31 and yesterday. As of yesterday there were 436 people in hospital with COVID. There have been 12 COVID deaths since Dec. 28, including a child under 9. Thursday’s 4,614 new cases broke another daily record. Even Mr. Kenney admitted that despite Omicron’s apparent less lethal nature things are likely to get worse before they get better. “We are all concerned that even a very small fraction of people being hospitalized on a huge number of people who’ve been infected can put unacceptable pressure on the health care system.”  But maybe next summer can be the Best Summer Ever." />
	<meta property="og:url" content="https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/" />
	<meta property="og:site_name" content="Alberta Politics" />
	<meta property="article:author" content="https://www.facebook.com/david.climenhaga.7" />
	<meta property="article:published_time" content="2022-01-05T05:44:42+00:00" />
	<meta property="og:image" content="https://albertapolitics.ca/wp-content/uploads/KenneyMain-73.png" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="572" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="David Climenhaga" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://albertapolitics.ca/#website","url":"https://albertapolitics.ca/","name":"Alberta Politics","description":"David Climenhaga&#039;s Alberta Politics Blog","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://albertapolitics.ca/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/#primaryimage","inLanguage":"en-CA","url":"https://albertapolitics.ca/wp-content/uploads/KenneyMain-73.png","contentUrl":"https://albertapolitics.ca/wp-content/uploads/KenneyMain-73.png","width":1000,"height":572,"caption":"Alberta Premier Jason Kenney at yesterday\u2019s COVID-19 news conference (Photo: Screenshot of Alberta Government video)."},{"@type":"WebPage","@id":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/#webpage","url":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/","name":"Alberta Premier Jason Kenney holds a news conference about nothing \u2013 the rest of us are just going to have to suck it up! - Alberta Politics","isPartOf":{"@id":"https://albertapolitics.ca/#website"},"primaryImageOfPage":{"@id":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/#primaryimage"},"datePublished":"2022-01-05T05:44:42+00:00","dateModified":"2022-01-05T05:44:42+00:00","author":{"@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779"},"breadcrumb":{"@id":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/"]}]},{"@type":"BreadcrumbList","@id":"https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://albertapolitics.ca/"},{"@type":"ListItem","position":2,"name":"All News","item":"https://albertapolitics.ca/top-news/"},{"@type":"ListItem","position":3,"name":"Alberta Premier Jason Kenney holds a news conference about nothing \u2013 the rest of us are just going to have to suck it up!"}]},{"@type":"Person","@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779","name":"David Climenhaga","image":{"@type":"ImageObject","@id":"https://albertapolitics.ca/#personlogo","inLanguage":"en-CA","url":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&d=mm&r=r","contentUrl":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&d=mm&r=r","caption":"David Climenhaga"},"sameAs":["https://www.facebook.com/david.climenhaga.7","https://twitter.com/djclimenhaga"],"url":"https://albertapolitics.ca/profile/david/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; Feed" href="https://albertapolitics.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; Comments Feed" href="https://albertapolitics.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up! Comments Feed" href="https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.3.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-58050199-1"  type="text/javascript" data-cfasync="false" data-wpfc-render="false" async></script>
			<script type="text/javascript" data-cfasync="false" data-wpfc-render="false">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</script>
				<!-- / Google Analytics by ExactMetrics -->
				<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-58050199-1"  type="text/javascript" data-cfasync="false" data-wpfc-render="false" async></script>
			<script type="text/javascript" data-cfasync="false" data-wpfc-render="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/albertapolitics.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://albertapolitics.ca/wp-includes/css/dist/block-library/style.min.css?ver=5.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-css-css'  href='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/css/cwp-poll.css?ver=5.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-jqui-css'  href='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/css/jquery-ui.css?ver=5.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://albertapolitics.ca/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.3.1.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='symple_shortcode_styles-css'  href='https://albertapolitics.ca/wp-content/plugins/symple-shortcodes/shortcodes/css/symple_shortcodes_styles.css?ver=5.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='Open-Sans-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.7.4" type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-progress-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/progress-bar-bootstrap.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='nouislider-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/nouislider.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='author-review-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/author-review.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='studio-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%7CUnifrakturMaguntia%7CRoboto%7CNoto+Sans%3A400%2C400italic%2C700italic%2C700%26subset%3Dlatin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='main-stylesheet-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/style.css?ver=1.1' type='text/css' media='all' />
<style id='main-stylesheet-inline-css' type='text/css'>
.mainnav-wrapper, .mainnav-wrapperheader4{border-top-style: solid;border-bottom-style: solid;border-top-width: 3px;border-bottom-width: 1px;border-color: #000;background-color: !important;}.header-logowrapper{background-image: url("");background-position: ;background-attachment: ;background-repeat: repeat;}body{background-image: url("");background-color: ;background-position: ;background-attachment: ;background-repeat: repeat;}.footer-widgetwrapper{background-image: url("");background-color: ;background-position: ;background-attachment: ;background-repeat: repeat;}.footer {background-color: ;}.moduletitle-wrapper > h3 > small {color: #666;}.dropdown-menu > li > a:hover,.dropdown-menu > li > a:focus {background-color: #dd3333!important;}.header-logoinside {}.header-top {background-color: ;}.header nav,.header-top, .header-address,.header-top a:link, .header-top a:visited{color: !important;}.header-logowrapper {background-color: ;}.header-logowrapper{color: !important;}.container-kodda {}.footer h3.widgettitle,.footer-widgetwrapper {color: ;}.footer-payment {color: ;}a,a:link,a:visited{ color: #000;}a:hover{ color: #fd5a53;}a:active{ color: ;}
</style>
<link rel='stylesheet' id='scroll-effects-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/library/css/scroll-effects/animate.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://albertapolitics.ca/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-responsive-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/style-responsive.css?ver=1.1' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/library/css/ie.css?ver=1.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='style-css'  href='https://albertapolitics.ca/wp-content/plugins/ilovenews-widget/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='avhec-widget-css'  href='https://albertapolitics.ca/wp-content/plugins/extended-categories-widget/4.2/css/avh-ec.widget.css?ver=3.10.0-dev.1' type='text/css' media='all' />
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/albertapolitics.ca","hash_tracking":"false","ua":"UA-58050199-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=7.3.0' defer onload='' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/albertapolitics.ca","hash_tracking":"false","ua":"UA-58050199-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.3.0' defer onload='' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' defer onload='' id='jquery-core-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' defer onload='' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' defer onload='' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/js/cwp-poll.js?ver=5.7.4' defer onload='' id='cwp-main-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/js/jquery.ui.datepicker.min.js?ver=5.7.4' defer onload='' id='cwp-main-datepicker-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.3.1.5' defer onload='' id='tp-tools-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.3.1.5' defer onload='' id='revmin-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/ilovenews-widget/js/custom.js?ver=1' defer onload='' id='custom-js'></script>
<link rel="https://api.w.org/" href="https://albertapolitics.ca/wp-json/" /><link rel="alternate" type="application/json" href="https://albertapolitics.ca/wp-json/wp/v2/posts/42051" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://albertapolitics.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://albertapolitics.ca/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://albertapolitics.ca/?p=42051' />
<link rel="alternate" type="application/json+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F01%2Falberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2022%2F01%2Falberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up%2F&#038;format=xml" />
<script type='text/javascript'>
 var CwppPlgSettings = {
   ajaxurl : 'https://albertapolitics.ca/wp-admin/admin-ajax.php',
   nonce : 'b60568b90c'
 };
</script>
<meta name="generator" content="Site Kit by Google 1.48.1" /><link rel="preload" href="https://albertapolitics.ca/wp-content/plugins/bloom/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous">
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.3.1.5 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21633434786/AP_Inline1', [300, 250], 'div-gpt-ad-1589337283650-0').addService(googletag.pubads());
    googletag.defineSlot('/21633434786/AP_Inline2', [300, 250], 'div-gpt-ad-1590463809738-0').addService(googletag.pubads());
	googletag.defineSlot('/21633434786/AP_Inline3', [300, 250], 'div-gpt-ad-1590463997675-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<script data-ad-client="ca-pub-6612591938398030" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body class="post-template-default single single-post postid-42051 single-format-standard symple-shortcodes  symple-shortcodes-responsive et_bloom wpb-js-composer js-comp-ver-5.0.1 vc_responsive">
<div class="wrapper">
<header class="header4">
	
	<div class="header-cartwrapper">
		<div id="toppanel">
  <div id="panel-header">
    <div class="content-spwrapper">  
    <div class="content-sp">
      <div class="widget-topslide1">
        
              </div>
      <div class="widget-topslide2">
        
              </div>
      <div class="widget-topslide3wrapper">	  
      <div class="widget-topslide3">
        
              </div>
    </div>
	</div>	
	</div>	
  </div>
  <!-- The tab on top -->
  <div class="tab">
  <ul class="login">
      <li id="toggle"> 
	  <a id="open" class="open" href="#"> 
	<i class="fa fa-plus"></i>
	  </a> 
	  <a id="close" style="display: none;" class="close-sp" href="#"> 
	<i class="fa fa-minus"></i>
	  </a> </li>
    </ul>
  </div>
</div>	</div>
	<div class="header-logowrapper">
		<div class="header-logobg">
			<div class="header-logo3">
				<div class="header-logoinside">
					<div class="header-left3">
						
											</div>
					<div class="header-center3"> <a href="https://albertapolitics.ca/"> <img src="/wp-content/uploads/upfw/albertapoliticslogo-ssl.png " alt="Alberta Politics"> </a> </div>
					<div class="header-right3">
												<!-- This content shows up if there are no widgets defined in the backend. -->

											</div>
				</div>
			</div>
			

			<div class="header4-3items">
			<div class="header4-left">
			</div>
			<div class="header4-center">
			David Climenhaga&#039;s Alberta Politics Blog			</div>
			<div class="header4-right">
			Wednesday, January 5, 2022			</div>	
</div>				
		</div>
		<div class="header-bottomborder"> </div>
	</div>
	<div class="mainnav-navwrapperboxed">
		<div class="mainnav-wrapperheader4">
			<div class="nav-mainwrapper">
				<nav class="navigation">
					<div class="container-kodda">
						<ul id="menu-top-nav" class="nav navbar-nav"><li id="menu-item-15918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-15929" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent"><a href="https://albertapolitics.ca/top-news/">All News</a></li>
<li id="menu-item-15936" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26057" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li id="menu-item-32647" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
<li id="menu-item-42009" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/subscribe-to-newsletter/">Subscribe to Newsletter</a></li>
</ul>					</div>
				</nav>
			</div>
		</div>
	</div>
</header>
<!-- end header --><div class="container">
		<div id="crumbs"><a href="https://albertapolitics.ca/">Home</a>  /  <a href="https://albertapolitics.ca/category/alberta-politics-2/">Alberta Politics</a>  /  <span>Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up!</span></div>	<div id="content">
		<div id="main" class="clearfix" role="main">
			<div class="topimage-poststyle5"> <a href="https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/" title="Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up!">
								<img src="https://albertapolitics.ca/wp-content/uploads/KenneyMain-73-900x425.png" alt="Alberta Politics"/></a> 
			<div class="module5-caption">Alberta Premier Jason Kenney at yesterday’s COVID-19 news conference (Photo: Screenshot of Alberta Government video). </div>			</div>
			<header class="article-header2">
				<div class="cat-single2">
					<a href="https://albertapolitics.ca/category/alberta-politics-2/" rel="category tag">Alberta Politics</a>				</div>
				<div class="articleheader-wrapper ">
					<h1 class="entry-title single-title" itemprop="headline">
						Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up!					</h1>
				</div>
				<div class="subtitle-single">
					<h4></h4>
				</div>
			</header>
			<div class="meta-onsinglepost2">
				<div class="author-single2">
					<div class="author-avatar"> <img alt='' src='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=77&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=154&#038;d=mm&#038;r=r 2x' class='avatar avatar-77 photo' height='77' width='77' loading='lazy'/> </div>
					<div class="author-detilsingle2">
						<div class="meta-detilsingle2">
							<h4>
								<a href="https://albertapolitics.ca/profile/david/" title="Posts by David Climenhaga" rel="author">David Climenhaga</a>							</h4>
						</div>
						<div class="meta-detilsingle2">
							Posted on 							 January 05, 2022, 12:44 am  </div>
					</div>
				</div>
				<div class="features-onsinglepost">
					<div class="share-fbpost"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/" target="_blank" class="share-btn facebook"> <i class="fa fa-facebook"></i> </a> </div>
					<div class="share-twitterpost"> <a href="https://twitter.com/share?url=https://albertapolitics.ca/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/" target="_blank"><i class="fa fa-twitter"></i></a> </div>
										<span class="readtime">6 mins</span>											
				</div>
			</div>
			<article id="post-42051" class="clearfix post-42051 post type-post status-publish format-standard has-post-thumbnail hentry category-alberta-politics-2 tag-alberta-politics tag-covid-19 tag-deena-hinshaw tag-jason-kenney tag-omicron-variant tag-united-conservative-party" >
				<section class="entry-content clearfix" itemprop="articleBody">
					<div class="entry-contentinside">
  <p class="p1">Jason Kenney held <a href="https://www.youtube.com/watch?v=yQvs97T_WzE&amp;list=PLvrD8tiHIX1L0ztJVj7n2YM7L6Ai5tp0s&amp;t=579s">a news conference</a> about nothing yesterday.</p>
<p class="p1">Alberta’s premier said he’s “very determined” there will be no additional delays and schools will reopen as planned on Monday, the continued rapid spread of the Omicron variant of COVID-19 notwithstanding. It doesn’t sound as if much has been done to make schools safer, so teachers will just have to suck it up.</p><div class="8t8uMj4k" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- /21633434786/AP_Inline1 -->
<div id='div-gpt-ad-1589337283650-0' style='width: 300px; height: 250px; text-align: center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1589337283650-0'); });
  </script>
</div></div>
<div id="attachment_42055" style="width: 236px" class="wp-caption alignright"><img aria-describedby="caption-attachment-42055" loading="lazy" class="size-medium wp-image-42055" src="https://albertapolitics.ca/wp-content/uploads/Hinshaw-47-226x300.png" alt="" width="226" height="300" srcset="https://albertapolitics.ca/wp-content/uploads/Hinshaw-47-226x300.png 226w, https://albertapolitics.ca/wp-content/uploads/Hinshaw-47-300x400.png 300w, https://albertapolitics.ca/wp-content/uploads/Hinshaw-47.png 500w" sizes="(max-width: 226px) 100vw, 226px" /><p id="caption-attachment-42055" class="wp-caption-text">Chief Medical Officer of Health Deena Hinshaw at yesterday’s news conference (Photo: Screenshot of Alberta Government video).</p></div>
<p class="p1"><a href="https://montreal.ctvnews.ca/quebec-may-soon-require-covid-19-vaccine-passports-to-access-liquor-and-cannabis-stores-1.5726905">Unlike other jurisdictions</a>, no additional measures to control transmission of the virus will be implemented. So hard-pressed health care workers will have to suck it up too.</p>
<p class="p1">Mr. Kenney urged Albertans as he habitually does to behave responsibly, get their boosters, reduce their social contacts, and take a rapid test if they can find one. We’ll all need to suck it up.</p>
<p class="p1">And while he said he’ll be meeting his COVID Cabinet Committee today, there was no indication any decisions will be made or new policies implemented by the United Conservative Party Government.</p>
<p class="p1">So, not nothing, exactly. Just the same old, same old.</p>
<p class="p1">If you were thinking of a certain TV sitcom often described as a show about nothing, the effect was similar, but not identical.</p>
<p class="p1">No comic genius like Larry David is plotting clever dialogue behind the scenes. There is no jangly music between the premier’s meaningless responses to reporters’ non sequiturs.</p><div class="Q5xRfCUA" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- /21633434786/AP_Inline2 -->
<div id='div-gpt-ad-1590463809738-0' style='width: 300px; height: 250px;text-align:center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1590463809738-0'); });
  </script>
</div></div>
<p class="p1">The only time Mr. Kenney showed much animation yesterday was when he pivoted in response to a journalist’s question to crossly blame Calgary City Council for <a href="https://www.sportsnet.ca/nhl/article/flames-confirm-agreement-calgary-event-centre-terminated/">the breakdown in negotiations</a> with a group of penny-pinching billionaires to build a new arena for the Calgary Flames with public money. (<a href="https://calgaryherald.com/news/local-news/ken-king-dies-leaving-a-legacy-of-leadership-business-acumen-and-commitment-to-sport">Ken King</a> must be spinning like a top in the Flames section of paradise!)</p>
<div id="attachment_42054" style="width: 352px" class="wp-caption alignright"><img aria-describedby="caption-attachment-42054" loading="lazy" class=" wp-image-42054" src="https://albertapolitics.ca/wp-content/uploads/David-239x300.jpg" alt="" width="342" height="429" srcset="https://albertapolitics.ca/wp-content/uploads/David-239x300.jpg 239w, https://albertapolitics.ca/wp-content/uploads/David-100x125.jpg 100w, https://albertapolitics.ca/wp-content/uploads/David.jpg 500w" sizes="(max-width: 342px) 100vw, 342px" /><p id="caption-attachment-42054" class="wp-caption-text">American comedian, writer, actor, director, and TV producer Larry David, at right, one of the creators of the Seinfeld series (Photo: David J. Climenhaga).</p></div>
<p class="p1">Still, things are happening <i>because</i> nothing is happening.</p>
<p class="p1">For example, last Friday pregnancy services were <a href="https://globalnews.ca/news/8482807/fort-saskatchewan-hospital-pregnancy-services-covid-staff/">temporarily shut down at the Fort Saskatchewan Community Hospital</a> because too many staff were off sick with COVID. The facility has since reopened, but it’s probably not the last time something like that will happen at an Alberta health care facility in the near future.</p>
<p class="p1">But there’s nothing you can do about that either. So the effect is alarming, not amusing.</p>
<p class="p1">Mr. Kenney and his cabinet have taken the same approach to the pandemic, in other words, as Alberta governments have traditionally taken to low fossil fuel resource prices: they’re praying for things to improve.</p>
<p class="p1">They pray for higher oil prices so that they can declare their stewardship a financial success; for lower hospitalizations because of Omicron’s presumed reduced lethality so that they can declare their crisis management an epidemiological triumph.</p>
<p class="p1">In other words, <a href="https://www.cbc.ca/news/canada/calgary/attack-ads-take-premier-to-task-for-lack-of-plan-1.757643">as was once said, unfairly, of Progressive Conservative premier Ed Stelmach</a>: <i>No plan … no plan …<span class="Apple-converted-space"> </span></i></p>
<p class="p1">Why schedule a news conference when there’s so little to say that the government can’t even be bothered to compose a news release? (And who ever heard of <i>that?</i>)</p>
<p class="p1">Well, I suppose Mr. Kenney needs to demonstrate to Albertans that notwithstanding his plummeting approval rate and all the talk of rebels in his caucus he’s still the premier, still in charge.</p>
<p class="p1">And Chief Medical Officer of Health Deena Hinshaw, who co-starred with him in yesterday’s unfunny episode of <i>Kenney</i>, is needed to read out the grim statistics.</p>
<p class="p1">COVID cases are breaking records again, she said. There are 34,276 <i>known</i> active cases in the province now, although there are probably many more.<span class="Apple-converted-space"> </span></p>
<p class="p1">There were nearly 13,000 new cases reported between Dec. 31 and yesterday. As of yesterday there were 436 people in hospital with COVID. There have been 12 COVID deaths since Dec. 28, including a child under 9.</p>
<p class="p1">Thursday’s 4,614 new cases broke another daily record.</p>
<p class="p1">Even Mr. Kenney admitted that despite Omicron’s apparent less lethal nature things are likely to get worse before they get better. “We are all concerned that even a very small fraction of people being hospitalized on a huge number of people who’ve been infected can put unacceptable pressure on the health care system.”<span class="Apple-converted-space"> </span></p>
<p class="p1">But maybe next summer can be the Best Summer Ever.</p>
<!-- /21633434786/AP_Inline3 -->
<div id='div-gpt-ad-1590463997675-0' style='width: 300px; height: 250px;text-align:center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1590463997675-0'); });
  </script>
</div></div>
										<footer class="article-footer">
												<p class="tags"><i class="fa fa-tags"></i> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/alberta-politics/" rel="tag">Alberta politics</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/covid-19/" rel="tag">COVID-19</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/deena-hinshaw/" rel="tag">Deena Hinshaw</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/jason-kenney/" rel="tag">Jason Kenney</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/omicron-variant/" rel="tag">Omicron Variant</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/united-conservative-party/" rel="tag">United Conservative Party</a></p>					</footer>
				</section>
				<div class="author-sticky">
									</div>
				<div class="prevnext-wrapper">
										<div class="postprev-wrapper">
						<div class="next-text">
							<h4>
							PREVIOUS ARTICLE							</h4>
							<h5><a href="https://albertapolitics.ca/2022/01/dont-imagine-ucps-eastern-slopes-coal-mining-plans-have-gone-away-jason-kenney-still-has-his-eyes-on-that-prize/">
								Don’t imagine UCP’s Eastern Slopes coal mining plans have gone away – Jason Kenney still has his eyes on that prize								</a></h5>
						</div>
					</div>
									</div>
				<div class="related-wrapper">
  <div class="related-maintitle">
    <h3>
      Related Post    </h3>
  </div>
      <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2021/06/buoyed-by-overwhelming-leadership-approval-vote-rachel-notley-sketches-outline-of-alberta-ndps-2023-campaign/" title="Buoyed by overwhelming leadership approval vote, Rachel Notley sketches outline of Alberta NDP’s 2023 campaign">
							<img src="https://albertapolitics.ca/wp-content/uploads/NotleyNewMain-400x450.png" alt="Buoyed by overwhelming leadership approval vote, Rachel Notley sketches outline of Alberta NDP’s 2023 campaign" data-original="https://albertapolitics.ca/wp-content/uploads/NotleyNewMain.png"/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2021/06/buoyed-by-overwhelming-leadership-approval-vote-rachel-notley-sketches-outline-of-alberta-ndps-2023-campaign/" title="Buoyed by overwhelming leadership approval vote, Rachel Notley sketches outline of Alberta NDP’s 2023 campaign">
          <h4>Buoyed by overwhelming leadership approval vote, Rachel Notley sketches outline of Alberta NDP’s 2023 campaign</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Jun 7					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2015/12/new-years-resolutions-time-for-albertas-conservative-leaders-to-speak-out-against-violent-and-misogynistic-political-speech/" title="New Year’s resolutions: Time for Alberta’s conservative leaders to speak out against violent and misogynistic political speech">
							<img src="https://albertapolitics.ca/wp-content/uploads/2015/12/3countdown-400x450.jpg" alt="New Year’s resolutions: Time for Alberta’s conservative leaders to speak out against violent and misogynistic political speech" data-original="https://albertapolitics.ca/wp-content/uploads/2015/12/3countdown.jpg"/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2015/12/new-years-resolutions-time-for-albertas-conservative-leaders-to-speak-out-against-violent-and-misogynistic-political-speech/" title="New Year’s resolutions: Time for Alberta’s conservative leaders to speak out against violent and misogynistic political speech">
          <h4>New Year’s resolutions: Time for Alberta’s conservative leaders to speak out against violent and misogynistic political speech</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Dec 29					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2018/10/ucp-candidates-reaction-to-storm-over-photos-with-soldiers-of-odin-we-had-no-idea/" title="Never mind the RSVP! UCP candidates’ reaction to storm over photos with ‘Soldiers of Odin’: We had no idea!">
							<img src="https://albertapolitics.ca/wp-content/uploads/WilliamsMain-400x450.jpg" alt="Never mind the RSVP! UCP candidates’ reaction to storm over photos with ‘Soldiers of Odin’: We had no idea!" data-original="https://albertapolitics.ca/wp-content/uploads/WilliamsMain.jpg"/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2018/10/ucp-candidates-reaction-to-storm-over-photos-with-soldiers-of-odin-we-had-no-idea/" title="Never mind the RSVP! UCP candidates’ reaction to storm over photos with ‘Soldiers of Odin’: We had no idea!">
          <h4>Never mind the RSVP! UCP candidates’ reaction to storm over photos with ‘Soldiers of Odin’: We had no idea!</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Oct 8					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2014/09/be-careful-what-you-wish-for-jim-prentice-walks-away-with-the-wildrose-political-play-book/" title="Be careful what you ask for! Jim Prentice walks away with the Wildrose political play book">
							<img src="http://albertadiary.ca/wp-content/uploads/2014/09/Prentice-1024x882.jpg" alt="Be careful what you ask for! Jim Prentice walks away with the Wildrose political play book" data-original=""/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2014/09/be-careful-what-you-wish-for-jim-prentice-walks-away-with-the-wildrose-political-play-book/" title="Be careful what you ask for! Jim Prentice walks away with the Wildrose political play book">
          <h4>Be careful what you ask for! Jim Prentice walks away with the Wildrose political play book</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Sep 22					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
  </div>				<!-- You can start editing here. -->
<h3 id="comments">
	One Comment	to: 	Alberta Premier Jason Kenney holds a news conference about nothing – the rest of us are just going to have to suck it up!</h3>
<ol class="commentlist">
		<li class="comment even thread-even depth-1">
		<article id="comment-201111" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/4eded828ddaab5e129bbadc0895af263?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/4eded828ddaab5e129bbadc0895af263?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Rocky</h4></div>
				<div class="comment-time">January 5th, 2022</div>
			</header>
						<section class="comment_content clearfix">
				<p>&#8220;Ken King must be spinning like a top in the Flames section of paradise!&#8221; I saw what you did there.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-201111' data-commentid="201111" data-postid="42051" data-belowelement="comment-201111" data-respondelement="respond" data-replyto="Reply to Rocky" aria-label='Reply to Rocky'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
</ol>
<nav id="comment-nav">
	<ul class="clearfix">
		<li>
					</li>
		<li>
					</li>
	</ul>
</nav>
<section id="respond" class="respond-form">
	<h3 id="comment-form-title">
		Leave a Reply	</h3>
	<div id="cancel-comment-reply">
		<p class="small">
			<a rel="nofollow" id="cancel-comment-reply-link" href="/2022/01/alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=alberta-premier-jason-kenney-holds-a-news-conference-about-nothing-the-rest-of-us-are-just-going-to-have-to-suck-it-up#respond" style="display:none;">Click here to cancel reply.</a>		</p>
	</div>
		<form action="https://albertapolitics.ca/wp-comments-post.php" method="post" id="commentform">
				<ul id="comment-form-elements" class="clearfix">
			<li>
				<label for="author">
					Name					(required)				</label>
				<input type="text" name="author" id="author" value="" placeholder="Your Name*" tabindex="1" aria-required='true' />
			</li>
			<li>
				<label for="email">
					Mail					(required)				</label>
				<small>
				(not be published)				</small>
				<input type="email" name="email" id="email" value="" placeholder="Your E-Mail*" tabindex="2" aria-required='true' />
			</li>
			<li>
				<label for="url">
					Website				</label>
				<input type="url" name="url" id="url" value="" placeholder="Got a website?" tabindex="3" />
			</li>
		</ul>
				<p>
			<textarea name="comment" id="comment" placeholder="Your Comment here..." tabindex="4"></textarea>
		</p>
		<input name="submit" type="submit" id="submit" class="btn btn-primary" tabindex="5" value="Submit" />
		<input type='hidden' name='comment_post_ID' value='42051' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
		<!--<div class="alert alert-info">
		<p id="allowed_tags" class="small"><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></p>
	</div>-->
			</form>
	</section>
			</article>
			<!-- end article -->
								</div>
		<div class="sidebar">
			<div class="sidebar-inside">
		<div id="search-4" class="widget widget_search"><form method="get" class="form-search" action="https://albertapolitics.ca/">
		<div class="col-lg-12">
			<div class="input-group">
				<input type="text" class="form-control search-query" name="s" placeholder="Looking for something">
				<span class="input-group-btn">
					<button type="submit" class="btn btn-primary" name="submit" id="searchsubmit" value="Go">Search</button>
				</span>
			</div>
		</div>
</form></div><div id="adwidget_imagewidget-6" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.parklandinstitute.ca/can_aimco_be_fixed' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Davids-web-ad-cover-1.jpg' alt='Ad' /></a></div><div id="text-3" class="widget widget_text"><div class="widgettitle-wrapper"><h3 class="widgettitle">Support ALBERTAPOLITICS.CA</h3></div>			<div class="textwidget"><p><center><a title="PayPal Donate" href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&amp;business=GZM2XBGM3G3S4&amp;lc=CA&amp;item_name=Alberta%20Diary%20Blog&amp;currency_code=CAD&amp;bn=PP%2dDonationsBF%3abtn_donateCC_LG%2egif%3aNonHosted" target="_blank" rel="noopener"><img src="https://albertapolitics.ca/wp-content/uploads/2014/12/paypal_donate.jpeg" alt="PayPal Donate Button" /></a></center></p>
</div>
		</div><div id="adwidget_imagewidget-8" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.pialberta.org/housingisahumanright' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Housing-is-a-human-right-1.png' alt='Ad' /></a></div><div id="extended-categories-3" class="widget widget_extended-categories"><!-- AVH Extended Categories version 3.10.0-dev.1 | http://blog.avirtualhome.com/wordpress-plugins/ --><div class="widgettitle-wrapper"><h3 class="widgettitle">Categories</h3></div><ul>	<li class="cat-item cat-item-4"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/canadian-politics/" title="View all posts filed under Canadian Politics">Canadian Politics</a><div class="avhec-widget-count"> (384)</div></div>
</li>
	<li class="cat-item cat-item-214"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/st-albert/" title="View all posts filed under St. Albert">St. Albert</a><div class="avhec-widget-count"> (26)</div></div>
</li>
	<li class="cat-item cat-item-350"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/geopolitics/" title="View all posts filed under Geopolitics">Geopolitics</a><div class="avhec-widget-count"> (70)</div></div>
</li>
	<li class="cat-item cat-item-393"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/news-satire/" title="View all posts filed under News Satire">News Satire</a><div class="avhec-widget-count"> (5)</div></div>
</li>
	<li class="cat-item cat-item-396 current-cat"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/alberta-politics-2/" title="View all posts filed under Alberta Politics">Alberta Politics</a><div class="avhec-widget-count"> (1,920)</div></div>
</li>
	<li class="cat-item cat-item-405"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/media-2/" title="View all posts filed under Media">Media</a><div class="avhec-widget-count"> (33)</div></div>
</li>
</ul></div><div id="adwidget_imagewidget-9" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.parklandinstitute.ca/bill_32' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Davids-web-ad-cover.jpg' alt='Ad' /></a></div>	</div>		</div>
	</div>
</div>
</div>
<div class="wrapper-footer">
	<footer class="footer">
			<div class="container-footer">
				<div class="footer-widgetwrapper">
						<div class="col-md-3">
																				</div>
						<div class="col-md-3">
							
													</div>
						<div class="col-md-3">
							
													</div>
						<div class="col-md-3">
							
													</div>
				</div>
			</div>
			<div class="slidefooter-trigger"> </div>
			<div id="slidebox"> <a class="slide-close"><img src="https://albertapolitics.ca/wp-content/themes/ilovenews/images/slide-close.png"  width="30" height="30" id="roti3" alt="pane"/> </a>
  <div class="slidebox-inner">
    <div class="slider-placecontent">
        
            </div>
  </div>
</div>		<div id="container-footer7">
			<div id="inner-footer" class="wrap clearfix">
			<div class="footer7-navwrapper">
					<div class="footer7-navbottom">
						<ul id="menu-footer-menu" class="nav navbar-nav"><li id="menu-item-26751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-26750" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26748" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-26745" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/privacy-policy/">Privacy Policy</a></li>
</ul>					</div>		
					
					<div class="footer7-copyright">
																© Copyright 2020 - Alberta Politics.													</div>
					</div>
					<div class="footer7-logowrapper"> 
					<div class="footer7-logo"> <a href=" "> <img src="/wp-content/uploads/upfw/albertapoliticslogo-small.png " alt="Alberta Politics"> </a>
					</div>
					</div>
						

			</div>
		</div>		
	</footer>
</div>
<!-- end .wrapper -->
<div class="back-top">
	<a href="#top"><span><i class="fa fa-angle-up fa-2x"></i></span></a>
</div>
	<style type="text/css"></style><link rel='stylesheet' id='et-gf-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700&#038;ver=1.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front_cus-css'  href='https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/js_composer.css?ver=5.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' defer onload='' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0' defer onload='"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0' defer onload='"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0' defer onload='"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4' defer onload='"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12' defer onload='"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2' defer onload='"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4' defer onload='"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/albertapolitics.ca\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.3' defer onload='' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/jquery.nouislider.min.js?ver=1.9' defer onload='' id='nouislider-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/jquery.appear.js?ver=2.0.4' defer onload='' id='appear-js'></script>
<script type='text/javascript' id='review-js-extra'>
/* <![CDATA[ */
var ajax_user_rate = {"url":"https:\/\/albertapolitics.ca\/wp-admin\/admin-ajax.php","nonce":"df929067c7"};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/review.js?ver=1.9' defer onload='' id='review-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/bloom/core/admin/js/common.js?ver=4.9.3' defer onload='' id='et-core-common-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/scripts.js?ver=1.1' defer onload='' id='bones-js-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/modernizr.custom.min.js?ver=1.1' defer onload='' id='bones-modernizr-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/bootstrap.min.js?ver=1.1' defer onload='' id='bones-bootstrap-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/fitvids.js?ver=1.1' defer onload='' id='fitvids-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.columnizer.js?ver=1.1' defer onload='' id='columnizer-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/theia-sticky-sidebar-min.js?ver=1.1' defer onload='' id='theia-sticky-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/wookmark.js?ver=1.1' defer onload='' id='wookmark-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/imagesloaded.min.js?ver=4.1.4' defer onload='' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/masonry.min.js?ver=4.2.2' defer onload='' id='masonry-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/inview.js?ver=1.1' defer onload='' id='inview-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/carouselfred.js?ver=1.1' defer onload='' id='carouselfred-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/viewportchecker.js?ver=1.1' defer onload='' id='viewportchecker-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.countTo.js?ver=1.1' defer onload='' id='countTo-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.easypiechart.min.js?ver=1.1' defer onload='' id='easypiechart-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/comment-reply.min.js?ver=5.7.4' defer onload='' id='comment-reply-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/wp-embed.min.js?ver=5.7.4' defer onload='' id='wp-embed-js'></script>
</body></html>