<!doctype html>
<!--[if lt IE 7]><html lang="en-CA" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-CA" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-CA" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-CA" class="no-js"><!--<![endif]-->
<head>
<meta charset="UTF-8">
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<![endif]-->
<!-- mobile meta (hooray!) -->
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<link rel="shortcut icon" href="						" />
<meta name="msapplication-TileColor" content="#f01d4f">
<link rel="pingback" href="https://albertapolitics.ca/xmlrpc.php">

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep - Alberta Politics</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep - Alberta Politics" />
	<meta property="og:description" content="Last week, Heather McPherson, New Democrat Member of Parliament for Edmonton Strathcona, was sounding as belligerent as any Alberta Conservative on the topic of what she termed “Russia’s aggression against Ukraine.” In a lead-up to a question in the House of Commons, a clip of which Ms. McPherson distributed on social media, the NDP’s deputy foreign affairs critic stated that “in recent weeks the Russian Federation has increased attacks on Ukraine’s eastern borders.” Wherever one stands on the tensions among Ukraine, its breakaway Russian-speaking regions and Russia since Ukraine tried to crush the separatist movement in the Donets Basin region in 2014, there is no evidence of Russian attacks in recent weeks. Saying otherwise is mere jingoism.  Russia made no secret, however, of the fact it had moved significant numbers of troops to its own territory adjacent to its western border. By doing so, it sent a clear message that any effort by Ukraine to retake Donbas, which would inevitably result in massive civilian casualties and tens of thousands of refugees flowing into Russia, would not be tolerated. Call that what you will, but whether or not one approves of Russian President Vladimir V. Putin or his government, no nation in a similar situation with millions of its kinsfolk and more than a half million of its passport holders threatened by a bellicose neighbouring government would do differently. Blood, as they say, is thicker than water, and even France, hardly Canada’s neighbour, was rumoured to have prepared to send paratroopers to Quebec in 1980 had the Quebec sovereignty referendum gone the other way.  In a publication of the Ukrainian National Federation of Canada, an organization sympathetic to the government in Kyiv, Ms. McPherson was quoted calling on Prime Minister Justin Trudeau to press for Ukraine to be put on a path to membership in the North Atlantic Treaty Organization and for Canada to send more troops to Ukraine. Given the tone of Ms. McPherson’s question in the House, we assume New Pathway Ukrainian News’s reporter quoted her accurately.  Of course, Russia is also highly unlikely to tolerate Ukraine’s membership in NATO – the military alliance that’s been trying to create a new mission for itself ever since its raison d’etre disappeared along with the Soviet Union in 1991.  Since we are paid-up members in relatively good standing of NATO, many Canadians may not like this, but presumably we are grown up enough to recognize why Russia would view American nuclear missiles in Ukraine in much the same existential light as Americans considered Russian nuclear missiles in Cuba in 1962.  One needs only to look at a map to see Russia’s problem, never mind NATO’s consistently aggressive behaviour on Russia’s borders and in the Baltic and Black seas throughout the past decade. And if you don’t think this is about the presence of nuclear weapons in Ukraine, consider the recent bluster by Ukraine’s ambassador to Germany, who complained that if NATO won’t roll in, Ukraine will have to get its own nukes.  Thankfully, Russia’s message seems to have been heard in Washington and Kyiv, and there is evidence that the tension along the line of contact between Ukraine and Donbas, which Ms. McPherson seems to want to increase, may have simmered down a little.  Which brings us to the question of just what the point was that Ms. McPherson intended to make, obviously with the complete support of her party’s leadership. She is, after all, also the NDP’s Deputy House Leader.  Her support for Operation Unifier, the Canadian Forces’ mission to train Ukraine’s soldiers in NATO’s ways, suggests this is an unannounced change in the NDP’s policy that Canada’s military should only participate in UN-mandated operations. So has the NDP succumbed to the surprisingly common phenomenon among North American progressives of needing to prove they can be just as belligerent as anyone on the right if only a vaguely progressive argument for military intervention somewhere can be made? Backing the current Ukrainian government in an effort to subjugate or ethnically cleanse a large part of its rebellious eastern border region doesn’t seem like a suitable place for Canadian progressives to scratch this itch.  Or is the NDP leadership trying to reassure Postmedia’s right-wing columnists that the resolution to disband the military at the party’s recent policy convention was nothing to worry about? No! No! We’re serious people too! If that’s what it is, I have news for the NDP: Postmedia’s columnists are never going to like you. And if you start giving them what you think they want, a lot of your own supporters are going to begin to have their doubts about you too.  Obviously we’re not going to disband the military, any more than we’re going to completely defund the police. This is realpolitik. After all, we have to do something to keep what’s left of our country’s moribund shipbuilding industry afloat! But surely the only non-conservative MP in Alberta can come up with better causes to cheer than helping NATO find a mission even more dangerous and potentially catastrophic than its recent failures in Afghanistan and Libya! Perhaps Ms. McPherson should be calling on the prime minister to use our troops in Alberta’s and Ontario’s hospitals to help with a deadly crisis that, right now, is actually killing Canadians. " />
	<meta property="og:url" content="https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/" />
	<meta property="og:site_name" content="Alberta Politics" />
	<meta property="article:author" content="https://www.facebook.com/david.climenhaga.7" />
	<meta property="article:published_time" content="2021-04-20T04:55:54+00:00" />
	<meta property="article:modified_time" content="2021-04-20T05:33:02+00:00" />
	<meta property="og:image" content="https://albertapolitics.ca/wp-content/uploads/McPherson-6.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="536" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="David Climenhaga">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="5 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://albertapolitics.ca/#website","url":"https://albertapolitics.ca/","name":"Alberta Politics","description":"David Climenhaga&#039;s Alberta Politics Blog","potentialAction":[{"@type":"SearchAction","target":"https://albertapolitics.ca/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/#primaryimage","inLanguage":"en-CA","url":"https://albertapolitics.ca/wp-content/uploads/McPherson-6.jpg","width":1000,"height":536,"caption":"Heather McPherson, New Democrat MP for Edmonton Strathcona, the only non-Conservative Member of Parliament in Alberta (Photo: David J. Climenhaga)."},{"@type":"WebPage","@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/#webpage","url":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/","name":"There are better ways for Alberta\u2019s only New Democrat to spend her time than calling for more Canadian troops on Russia\u2019s doorstep - Alberta Politics","isPartOf":{"@id":"https://albertapolitics.ca/#website"},"primaryImageOfPage":{"@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/#primaryimage"},"datePublished":"2021-04-20T04:55:54+00:00","dateModified":"2021-04-20T05:33:02+00:00","author":{"@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779"},"breadcrumb":{"@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/"]}]},{"@type":"BreadcrumbList","@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://albertapolitics.ca/","url":"https://albertapolitics.ca/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://albertapolitics.ca/top-news/","url":"https://albertapolitics.ca/top-news/","name":"All News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/","url":"https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/","name":"There are better ways for Alberta\u2019s only New Democrat to spend her time than calling for more Canadian troops on Russia\u2019s doorstep"}}]},{"@type":"Person","@id":"https://albertapolitics.ca/#/schema/person/01c0fbb2d5b9c8762f4928580a962779","name":"David Climenhaga","image":{"@type":"ImageObject","@id":"https://albertapolitics.ca/#personlogo","inLanguage":"en-CA","url":"https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=96&d=mm&r=r","caption":"David Climenhaga"},"sameAs":["https://www.facebook.com/david.climenhaga.7","https://twitter.com/djclimenhaga"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; Feed" href="https://albertapolitics.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; Comments Feed" href="https://albertapolitics.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alberta Politics &raquo; There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep Comments Feed" href="https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v6.7.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-58050199-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var em_version = '6.7.0';
				var em_track_user = true;
				var em_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-58050199-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( em_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dNDMyYj' : true,
						                    });
					__gtagTracker( 'config', 'UA-58050199-1', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by ExactMetrics -->
				<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-58050199-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-58050199-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-58050199-1', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/albertapolitics.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://albertapolitics.ca/wp-includes/css/dist/block-library/style.min.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-css-css'  href='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/css/cwp-poll.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='cwp-jqui-css'  href='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/css/jquery-ui.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://albertapolitics.ca/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.3.1.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='symple_shortcode_styles-css'  href='https://albertapolitics.ca/wp-content/plugins/symple-shortcodes/shortcodes/css/symple_shortcodes_styles.css?ver=5.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='Open-Sans-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.6.3" type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-progress-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/progress-bar-bootstrap.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='nouislider-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/nouislider.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='author-review-css'  href='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/css/author-review.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='studio-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%7CUnifrakturMaguntia%7CRoboto%7CNoto+Sans%3A400%2C400italic%2C700italic%2C700%26subset%3Dlatin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='main-stylesheet-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/style.css?ver=1.1' type='text/css' media='all' />
<style id='main-stylesheet-inline-css' type='text/css'>
.mainnav-wrapper, .mainnav-wrapperheader4{border-top-style: solid;border-bottom-style: solid;border-top-width: 3px;border-bottom-width: 1px;border-color: #000;background-color: !important;}.header-logowrapper{background-image: url("");background-position: ;background-attachment: ;background-repeat: repeat;}body{background-image: url("");background-color: ;background-position: ;background-attachment: ;background-repeat: repeat;}.footer-widgetwrapper{background-image: url("");background-color: ;background-position: ;background-attachment: ;background-repeat: repeat;}.footer {background-color: ;}.moduletitle-wrapper > h3 > small {color: #666;}.dropdown-menu > li > a:hover,.dropdown-menu > li > a:focus {background-color: #dd3333!important;}.header-logoinside {}.header-top {background-color: ;}.header nav,.header-top, .header-address,.header-top a:link, .header-top a:visited{color: !important;}.header-logowrapper {background-color: ;}.header-logowrapper{color: !important;}.container-kodda {}.footer h3.widgettitle,.footer-widgetwrapper {color: ;}.footer-payment {color: ;}a,a:link,a:visited{ color: #000;}a:hover{ color: #fd5a53;}a:active{ color: ;}
</style>
<link rel='stylesheet' id='scroll-effects-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/library/css/scroll-effects/animate.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://albertapolitics.ca/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-responsive-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/style-responsive.css?ver=1.1' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://albertapolitics.ca/wp-content/themes/ilovenews/library/css/ie.css?ver=1.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='style-css'  href='https://albertapolitics.ca/wp-content/plugins/ilovenews-widget/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='avhec-widget-css'  href='https://albertapolitics.ca/wp-content/plugins/extended-categories-widget/4.2/css/avh-ec.widget.css?ver=3.10.0-dev.1' type='text/css' media='all' />
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/albertapolitics.ca","hash_tracking":"false","ua":"UA-58050199-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=6.7.0' defer onload='' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/albertapolitics.ca","hash_tracking":"false","ua":"UA-58050199-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' defer onload='' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' defer onload='' id='jquery-core-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' defer onload='' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' defer onload='' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/js/cwp-poll.js?ver=5.6.3' defer onload='' id='cwp-main-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/cardoza-wordpress-poll/public/js/jquery.ui.datepicker.min.js?ver=5.6.3' defer onload='' id='cwp-main-datepicker-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.3.1.5' defer onload='' id='tp-tools-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.3.1.5' defer onload='' id='revmin-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/ilovenews-widget/js/custom.js?ver=1' defer onload='' id='custom-js'></script>
<link rel="https://api.w.org/" href="https://albertapolitics.ca/wp-json/" /><link rel="alternate" type="application/json" href="https://albertapolitics.ca/wp-json/wp/v2/posts/38465" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://albertapolitics.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://albertapolitics.ca/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://albertapolitics.ca/?p=38465' />
<link rel="alternate" type="application/json+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2021%2F04%2Fthere-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://albertapolitics.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falbertapolitics.ca%2F2021%2F04%2Fthere-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep%2F&#038;format=xml" />
<script type='text/javascript'>
 var CwppPlgSettings = {
   ajaxurl : 'https://albertapolitics.ca/wp-admin/admin-ajax.php',
   nonce : 'e4f6de5003'
 };
</script>
<meta name="generator" content="Site Kit by Google 1.29.0" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.3.1.5 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21633434786/AP_Inline1', [300, 250], 'div-gpt-ad-1589337283650-0').addService(googletag.pubads());
    googletag.defineSlot('/21633434786/AP_Inline2', [300, 250], 'div-gpt-ad-1590463809738-0').addService(googletag.pubads());
	googletag.defineSlot('/21633434786/AP_Inline3', [300, 250], 'div-gpt-ad-1590463997675-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<script data-ad-client="ca-pub-6612591938398030" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body class="post-template-default single single-post postid-38465 single-format-standard symple-shortcodes  symple-shortcodes-responsive wpb-js-composer js-comp-ver-5.0.1 vc_responsive">
<div class="wrapper">
<header class="header4">
	
	<div class="header-cartwrapper">
		<div id="toppanel">
  <div id="panel-header">
    <div class="content-spwrapper">  
    <div class="content-sp">
      <div class="widget-topslide1">
        
              </div>
      <div class="widget-topslide2">
        
              </div>
      <div class="widget-topslide3wrapper">	  
      <div class="widget-topslide3">
        
              </div>
    </div>
	</div>	
	</div>	
  </div>
  <!-- The tab on top -->
  <div class="tab">
  <ul class="login">
      <li id="toggle"> 
	  <a id="open" class="open" href="#"> 
	<i class="fa fa-plus"></i>
	  </a> 
	  <a id="close" style="display: none;" class="close-sp" href="#"> 
	<i class="fa fa-minus"></i>
	  </a> </li>
    </ul>
  </div>
</div>	</div>
	<div class="header-logowrapper">
		<div class="header-logobg">
			<div class="header-logo3">
				<div class="header-logoinside">
					<div class="header-left3">
						
											</div>
					<div class="header-center3"> <a href="https://albertapolitics.ca/"> <img src="/wp-content/uploads/upfw/albertapoliticslogo-ssl.png " alt="Alberta Politics"> </a> </div>
					<div class="header-right3">
												<!-- This content shows up if there are no widgets defined in the backend. -->

											</div>
				</div>
			</div>
			

			<div class="header4-3items">
			<div class="header4-left">
			</div>
			<div class="header4-center">
			David Climenhaga&#039;s Alberta Politics Blog			</div>
			<div class="header4-right">
			Tuesday, April 20, 2021			</div>	
</div>				
		</div>
		<div class="header-bottomborder"> </div>
	</div>
	<div class="mainnav-navwrapperboxed">
		<div class="mainnav-wrapperheader4">
			<div class="nav-mainwrapper">
				<nav class="navigation">
					<div class="container-kodda">
						<ul id="menu-top-nav" class="nav navbar-nav"><li id="menu-item-15918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-15929" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent"><a href="https://albertapolitics.ca/top-news/">All News</a></li>
<li id="menu-item-15936" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26057" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/albertas-premiers-since-launch-albertapolitics-ca/">Premiers</a></li>
<li id="menu-item-32647" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/land-acknowledgement/">Land Acknowledgement</a></li>
</ul>					</div>
				</nav>
			</div>
		</div>
	</div>
</header>
<!-- end header --><div class="container">
		<div id="crumbs"><a href="https://albertapolitics.ca/">Home</a>  /  <a href="https://albertapolitics.ca/category/canadian-politics/">Canadian Politics</a>  /  <span>There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep</span></div>	<div id="content">
		<div id="main" class="clearfix" role="main">
			<div class="topimage-poststyle5"> <a href="https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/" title="There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep">
								<img src="https://albertapolitics.ca/wp-content/uploads/McPherson-6-900x425.jpg" alt="Alberta Politics"/></a> 
			<div class="module5-caption">Heather McPherson, New Democrat MP for Edmonton Strathcona, the only non-Conservative Member of Parliament in Alberta (Photo: David J. Climenhaga). </div>			</div>
			<header class="article-header2">
				<div class="cat-single2">
					<a href="https://albertapolitics.ca/category/canadian-politics/" rel="category tag">Canadian Politics</a>				</div>
				<div class="articleheader-wrapper ">
					<h1 class="entry-title single-title" itemprop="headline">
						There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep					</h1>
				</div>
				<div class="subtitle-single">
					<h4></h4>
				</div>
			</header>
			<div class="meta-onsinglepost2">
				<div class="author-single2">
					<div class="author-avatar"> <img alt='' src='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=77&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=154&#038;d=mm&#038;r=r 2x' class='avatar avatar-77 photo' height='77' width='77' loading='lazy'/> </div>
					<div class="author-detilsingle2">
						<div class="meta-detilsingle2">
							<h4>
								<a href="https://albertapolitics.ca/profile/david/" title="Posts by David Climenhaga" rel="author">David Climenhaga</a>							</h4>
						</div>
						<div class="meta-detilsingle2">
							Posted on 							 April 20, 2021, 12:55 am  </div>
					</div>
				</div>
				<div class="features-onsinglepost">
					<div class="share-fbpost"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/" target="_blank" class="share-btn facebook"> <i class="fa fa-facebook"></i> </a> </div>
					<div class="share-twitterpost"> <a href="https://twitter.com/share?url=https://albertapolitics.ca/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/" target="_blank"><i class="fa fa-twitter"></i></a> </div>
										<span class="readtime">7 mins</span>											
				</div>
			</div>
			<article id="post-38465" class="clearfix post-38465 post type-post status-publish format-standard has-post-thumbnail hentry category-canadian-politics tag-alberta-politics tag-canadian-politics tag-geopolitics tag-heather-mcpherson tag-new-democratic-party tag-russia tag-ukraine" >
				<section class="entry-content clearfix" itemprop="articleBody">
					<div class="entry-contentinside">
  <p class="p1">Last week, Heather McPherson, New Democrat Member of Parliament for Edmonton Strathcona, was sounding as belligerent as any Alberta Conservative on the topic of what she termed “Russia’s aggression against Ukraine.”</p>
<p class="p1">In a lead-up to a question in the House of Commons, <a href="https://twitter.com/HMcPhersonMP/status/1383141972567683076">a clip of which Ms. McPherson distributed on social media</a>, the NDP’s deputy foreign affairs critic stated that “in recent weeks the Russian Federation has increased attacks on Ukraine’s eastern borders.”</p><div class="tEthanbH" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- /21633434786/AP_Inline1 -->
<div id='div-gpt-ad-1589337283650-0' style='width: 300px; height: 250px; text-align: center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1589337283650-0'); });
  </script>
</div></div>
<div id="attachment_38470" style="width: 252px" class="wp-caption alignright"><img aria-describedby="caption-attachment-38470" loading="lazy" class="size-medium wp-image-38470" src="https://albertapolitics.ca/wp-content/uploads/Trudeau-21-242x300.png" alt="" width="242" height="300" srcset="https://albertapolitics.ca/wp-content/uploads/Trudeau-21-242x300.png 242w, https://albertapolitics.ca/wp-content/uploads/Trudeau-21-100x125.png 100w, https://albertapolitics.ca/wp-content/uploads/Trudeau-21.png 500w" sizes="(max-width: 242px) 100vw, 242px" /><p id="caption-attachment-38470" class="wp-caption-text">Canadian Prime Minister Justin Trudeau (Photo: Justin Trudeau/Flickr).</p></div>
<p class="p1">Wherever one stands on the tensions among Ukraine, its breakaway Russian-speaking regions and Russia since Ukraine tried to crush the separatist movement in the Donets Basin region in 2014, there is no evidence of Russian <i>attacks</i> in recent weeks. Saying otherwise is mere jingoism.<span class="Apple-converted-space"> </span></p>
<p class="p1">Russia made no secret, however, of the fact it had moved significant numbers of troops to its own territory adjacent to its western border. By doing so, it sent a clear message that any effort by Ukraine to retake Donbas, which would inevitably result in massive civilian casualties and tens of thousands of refugees flowing into Russia, would not be tolerated.</p>
<p class="p1">Call that what you will, but whether or not one approves of Russian President Vladimir V. Putin or his government, no nation in a similar situation with millions of its kinsfolk and more than a half million of its passport holders threatened by a bellicose neighbouring government would do differently.</p>
<p class="p1">Blood, as they say, is thicker than water, and even France, hardly Canada’s neighbour, was rumoured to have prepared to send paratroopers to Quebec in 1980 had the Quebec sovereignty referendum gone the other way.<span class="Apple-converted-space"> </span></p>
<p class="p1">In a publication of the Ukrainian National Federation of Canada, an organization sympathetic to the government in Kyiv, <a href="https://www.newpathway.ca/zelenskyy-asks-trudeau-to-help-ukraine-clear-path-to-nato/?fbclid=IwAR3ydFxBLjvbiiqdrsdH-oMK6sMZ5h9C2XwikLZJbZf1HgViCkFX05OCiaQ">Ms. McPherson was quoted</a> calling on Prime Minister Justin Trudeau to press for Ukraine to be put on a path to membership in the North Atlantic Treaty Organization and for Canada to send more troops to Ukraine.</p>
<p class="p1">Given the tone of Ms. McPherson’s question in the House, we assume <i>New Pathway Ukrainian New</i>s’s reporter quoted her accurately.<span class="Apple-converted-space"> </span></p><div class="y6FIbtZo" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- /21633434786/AP_Inline2 -->
<div id='div-gpt-ad-1590463809738-0' style='width: 300px; height: 250px;text-align:center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1590463809738-0'); });
  </script>
</div></div>
<p class="p1">Of course, Russia is also highly unlikely to tolerate Ukraine’s membership in NATO – the military alliance that’s been trying to create a new mission for itself ever since its <i>raison d’etre</i> disappeared along with the Soviet Union in 1991.<span class="Apple-converted-space"> </span></p>
<div id="attachment_38471" style="width: 229px" class="wp-caption alignright"><img aria-describedby="caption-attachment-38471" loading="lazy" class="size-medium wp-image-38471" src="https://albertapolitics.ca/wp-content/uploads/Putin-1-219x300.jpg" alt="" width="219" height="300" srcset="https://albertapolitics.ca/wp-content/uploads/Putin-1-219x300.jpg 219w, https://albertapolitics.ca/wp-content/uploads/Putin-1.jpg 500w" sizes="(max-width: 219px) 100vw, 219px" /><p id="caption-attachment-38471" class="wp-caption-text">Russian President Vladimir V. Putin (Photo: Kremlin.ru).</p></div>
<p class="p1">Since we are paid-up members in relatively good standing of NATO, many Canadians may not like this, but presumably we are grown up enough to recognize why Russia would view American nuclear missiles in Ukraine in much the same existential light as Americans considered Russian nuclear missiles in Cuba in 1962.<span class="Apple-converted-space"> </span></p>
<p class="p1">One needs only to look at a map to see Russia’s problem, never mind NATO’s consistently aggressive behaviour on Russia’s borders and in the Baltic and Black seas throughout the past decade. And if you don’t think this is about the presence of nuclear weapons in Ukraine, consider <a href="https://www.aljazeera.com/news/2021/4/16/ukraine-may-seek-nuclear-weapons-if-left-out-of-nato-diplomat">the recent bluster by Ukraine’s ambassador to Germany</a>, who complained that if NATO won’t roll in, Ukraine will have to get its own nukes.<span class="Apple-converted-space"> </span></p>
<p class="p1">Thankfully, Russia’s message seems to have been heard in Washington and Kyiv, and there is evidence that the tension along the line of contact between Ukraine and Donbas, which Ms. McPherson seems to want to increase, may have simmered down a little.<span class="Apple-converted-space"> </span></p>
<p class="p1">Which brings us to the question of just what the point was that Ms. McPherson intended to make, obviously with the complete support of her party’s leadership. She is, after all, also the NDP’s Deputy House Leader.<span class="Apple-converted-space"> </span></p>
<p class="p1">Her support for Operation Unifier, the Canadian Forces’ mission to train Ukraine’s soldiers in NATO’s ways, suggests this is an unannounced change in the NDP’s policy that Canada’s military should only participate in UN-mandated operations.</p>
<p class="p1">So has the NDP succumbed to the surprisingly common phenomenon among North American progressives of needing to prove they can be just as belligerent as anyone on the right if only a vaguely progressive argument for military intervention somewhere can be made?</p>
<p class="p1">Backing the current Ukrainian government in an effort to subjugate or ethnically cleanse a large part of its rebellious eastern border region doesn’t seem like a suitable place for Canadian progressives to scratch this itch.<span class="Apple-converted-space"> </span></p>
<p class="p1">Or is the NDP leadership trying to reassure Postmedia’s right-wing columnists that <a href="https://www.cbc.ca/news/politics/singh-ndp-rejects-extreme-policy-resoloutions-1.5978728">the resolution to disband the military</a> at the party’s recent policy convention was nothing to worry about? <i>No! No! We’re serious people too!</i></p>
<p class="p1">If that’s what it is, I have news for the NDP: <i>Postmedia’s columnists are never going to like you.</i> And if you start giving them what you think they want, a lot of your own supporters are going to begin to have their doubts about you too.<span class="Apple-converted-space"> </span></p>
<p class="p1">Obviously we’re not going to disband the military, any more than we’re going to completely defund the police. This is <i>realpolitik.</i> After all, we have to do something to keep <a href="https://www.defensenews.com/naval/2021/02/26/canadas-new-frigate-is-getting-heavier-more-expensive/">what’s left of our country’s moribund shipbuilding industry afloat</a>!</p>
<p class="p1">But surely the only non-conservative MP in Alberta can come up with better causes to cheer than helping NATO find a mission even more dangerous and potentially catastrophic than its recent failures in Afghanistan and Libya!</p>
<p class="p1">Perhaps Ms. McPherson should be calling on the prime minister to use our troops in Alberta’s and Ontario’s hospitals to help with a deadly crisis that, right now, is actually killing Canadians.<span class="Apple-converted-space"> </span></p>
<!-- /21633434786/AP_Inline3 -->
<div id='div-gpt-ad-1590463997675-0' style='width: 300px; height: 250px;text-align:center;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1590463997675-0'); });
  </script>
</div></div>
										<footer class="article-footer">
												<p class="tags"><i class="fa fa-tags"></i> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/alberta-politics/" rel="tag">Alberta politics</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/canadian-politics/" rel="tag">Canadian Politics</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/geopolitics/" rel="tag">Geopolitics</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/heather-mcpherson/" rel="tag">Heather McPherson</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/new-democratic-party/" rel="tag">New Democratic Party</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/russia/" rel="tag">Russia</a> <a class="btn btn-xs btn-primary" href="https://albertapolitics.ca/tag/ukraine/" rel="tag">Ukraine</a></p>					</footer>
				</section>
				<div class="author-sticky">
									</div>
				<div class="prevnext-wrapper">
										<div class="postprev-wrapper">
						<div class="next-text">
							<h4>
							PREVIOUS ARTICLE							</h4>
							<h5><a href="https://albertapolitics.ca/2021/04/why-conservatives-love-the-monarchy-and-how-without-a-canadian-monarch-real-republicans-could-be-democrats/">
								Why Conservatives love the monarchy, and how without a Canadian monarch real republicans could be democrats								</a></h5>
						</div>
					</div>
									</div>
				<div class="related-wrapper">
  <div class="related-maintitle">
    <h3>
      Related Post    </h3>
  </div>
      <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2015/10/justin-trudeaus-victory-speech-was-generous-but-toughly-repudiated-stephen-harpers-divisive-rule/" title="Justin Trudeau’s victory speech was generous, but toughly repudiated Stephen Harper’s divisive rule">
							<img src="https://albertapolitics.ca/wp-content/uploads/2015/10/TRUDEAU_SPEAKS-JPG-400x450.jpg" alt="Justin Trudeau’s victory speech was generous, but toughly repudiated Stephen Harper’s divisive rule" data-original="https://albertapolitics.ca/wp-content/uploads/2015/10/TRUDEAU_SPEAKS-JPG.jpg"/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2015/10/justin-trudeaus-victory-speech-was-generous-but-toughly-repudiated-stephen-harpers-divisive-rule/" title="Justin Trudeau’s victory speech was generous, but toughly repudiated Stephen Harper’s divisive rule">
          <h4>Justin Trudeau’s victory speech was generous, but toughly repudiated Stephen Harper’s divisive rule</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Oct 20					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2016/06/omg-energy-industry-faces-existential-threat-hollywood-ever-growing-matrix-activists/" title="OMG! Energy industry faces ‘existential threat’ from Hollywood, ‘ever-growing matrix of activists’">
							<img src="https://albertapolitics.ca/wp-content/uploads/2016/06/BradBaby-400x450.jpg" alt="OMG! Energy industry faces ‘existential threat’ from Hollywood, ‘ever-growing matrix of activists’" data-original="https://albertapolitics.ca/wp-content/uploads/2016/06/BradBaby.jpg"/></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2016/06/omg-energy-industry-faces-existential-threat-hollywood-ever-growing-matrix-activists/" title="OMG! Energy industry faces ‘existential threat’ from Hollywood, ‘ever-growing matrix of activists’">
          <h4>OMG! Energy industry faces ‘existential threat’ from Hollywood, ‘ever-growing matrix of activists’</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Jun 15					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2017/04/good-news-bad-news-tory-candidate-maxime-bernier-boston-stranger-packs-carpet-bag-flies-home/" title="Good news-bad news for Tory candidate Maxime Bernier as Boston Stranger packs up his carpet bag and heads home">
							<img src="https://albertapolitics.ca/wp-content/uploads/2017/04/Bernier-205x300.jpg" alt="Good news-bad news for Tory candidate Maxime Bernier as Boston Stranger packs up his carpet bag and heads home" data-original="" /></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2017/04/good-news-bad-news-tory-candidate-maxime-bernier-boston-stranger-packs-carpet-bag-flies-home/" title="Good news-bad news for Tory candidate Maxime Bernier as Boston Stranger packs up his carpet bag and heads home">
          <h4>Good news-bad news for Tory candidate Maxime Bernier as Boston Stranger packs up his carpet bag and heads home</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Apr 27					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
    <div class="col-md-3">
      <div class="overlay-wrapper">
    <div class="related-thumb">
<div class="overlay">
</div>		
      <div class="thumb-zoom"> <a href="https://albertapolitics.ca/2015/10/the-story-this-far-from-alberta-the-western-alienation-narrative-starts-today/" title="The story thus far from Alberta: the Western Alienation narrative starts today">
							<img src="https://albertapolitics.ca/wp-content/uploads/2015/10/Trudeau-Lougheed-300x184.jpg" alt="The story thus far from Alberta: the Western Alienation narrative starts today" data-original="https://albertapolitics.ca/wp-content/uploads/2015/10/jermiah.jpg" /></a>
        <div class="related-title"> <a href="https://albertapolitics.ca/2015/10/the-story-this-far-from-alberta-the-western-alienation-narrative-starts-today/" title="The story thus far from Alberta: the Western Alienation narrative starts today">
          <h4>The story thus far from Alberta: the Western Alienation narrative starts today</h4>
          </a> 
					<div class="module4-meta">
						Climenhaga<span> / </span>
						Oct 21					<div class="samareviewyellow-inmoduleright">		

					

					</div>
					</div>			  
		  </div>
      </div>
    </div>
  </div>
  </div>
  </div>				<!-- You can start editing here. -->
<h3 id="comments">
	12 Comments	to: 	There are better ways for Alberta’s only New Democrat to spend her time than calling for more Canadian troops on Russia’s doorstep</h3>
<ol class="commentlist">
		<li class="comment even thread-even depth-1">
		<article id="comment-172492" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/0f667d186e4e7a97e1ad4b0ca73da70f?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/0f667d186e4e7a97e1ad4b0ca73da70f?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Sub-Boreal</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>I liked Ms. McPherson better when the worst she could do was root for pipelines.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172492' data-commentid="172492" data-postid="38465" data-belowelement="comment-172492" data-respondelement="respond" data-replyto="Reply to Sub-Boreal" aria-label='Reply to Sub-Boreal'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1">
		<article id="comment-172495" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/4e2b1b46fb7ac782985d81388f7c1e7d?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/4e2b1b46fb7ac782985d81388f7c1e7d?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Martin</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Dear David,</p>
<p>I often agree with you. Not often, all the time &#8211; as far as I can remember.  This time, however, you got it wrong. Very wrong. Not sure whether you are trying to be the “removed geo-political observer” or falling into the “progressive” good vs. bad imperialists trap. I came to Canada from that tortured part of the world (not Ukraine, to be clear) and for me NATO didn’t loose its raison d’etre, but got an elevated one.  Believe me, its presence in the region serves the population of countries that are under constant Russian threat, rather than just annoy Putin. Just check out the recent Czech news, or Sputnik V stories to get a hint what I am talking about. And no &#8211; it’s not government in Kyiv &#8211; it’s the Government of Ukraine that defends its territory. As I hope GoC (even a NDP one) would defend Alberta against the loud  Trumpist minoryty, if it came to it.<br />
Best,<br />
M.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172495' data-commentid="172495" data-postid="38465" data-belowelement="comment-172495" data-respondelement="respond" data-replyto="Reply to Martin" aria-label='Reply to Martin'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
<ul class="children">
	<li class="comment even depth-2">
		<article id="comment-172521" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/f59f30566d97f1d51ed4b84d14e521f2?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/f59f30566d97f1d51ed4b84d14e521f2?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>John Sokolowski</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Martin , I would like your reaction  to an impression that I have formed over time . It seems to me that Dave&#8217;s interpretation of the events in Ukraine slavishly follows Russian propaganda . What do you, as some one from Eastern Europe , think , Martin ? </p>
<p>So, Dave,  put our minds at rest and cite your sources .Where do you get your information from concerning the Russian Ukrainian War . After all , Dave, you are not writing Alberta curricula here and can be expected to cite your sources .</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172521' data-commentid="172521" data-postid="38465" data-belowelement="comment-172521" data-respondelement="respond" data-replyto="Reply to John Sokolowski" aria-label='Reply to John Sokolowski'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
<ul class="children">
	<li class="comment byuser comment-author-david bypostauthor odd alt depth-3">
		<article id="comment-172522" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/9acc1f4feb640dc310e08ee0449bb4b0?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>David Climenhaga</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>John: Thanks for your query. I read quite widely about Russia and Eastern Europe, including some sources that I think we would both agree are legitimately described as Russian propaganda. Like all propaganda, they need to be read carefully with this in mind. My principal daily sources for news on the region are the New York Times and the Washington Post, which cannot be described as pro-Russian publications and which sometimes offer tendentious (in my view) interpretations of events, but are nevertheless relatively reliable and commendably quick, and have the advantage from my perspective of having sold me subscriptions. For a reasonably balanced perspective, I often recommend the <a href="https://irrussianality.wordpress.com/" rel="nofollow ugc">Irrussianality blog</a> published by Professor Paul Robinson of the University of Ottawa for providing a view that is, in my view, reasonably balanced and appropriately skeptical of the claims of both sides. Judging from the tone of your comment, I imagine you will not find him a credible source &#8211; and his having taken up writing opinion pieces for RT won&#8217;t help. However, I stand by my assessment of his work. Since I am not writing curriculum at taxpayer expense, I don&#8217;t think a full bibliography is required. DJC</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172522' data-commentid="172522" data-postid="38465" data-belowelement="comment-172522" data-respondelement="respond" data-replyto="Reply to David Climenhaga" aria-label='Reply to David Climenhaga'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1">
		<article id="comment-172497" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/b871332e1c19b2790496fc2bca034862?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/b871332e1c19b2790496fc2bca034862?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Bill Malcolm</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Those darn Russkies, constantly placing troops within their own borders so close to NATO troops stationed in other countries bordering theirs! It&#8217;s provocative, that&#8217;s what! NATO forces have the right to be there protecting human rights, watching out for aggressive Russian forays that might upset the glorious European way of life.</p>
<p>There&#8217;s only so much BS a rational human can absorb, most of it generated at the US State Department for the last thirty years, repeated verbatim by our media so we get only one side of the argument. Of course, with Putin being a &#8220;killer&#8221;, who&#8217;d want to hear what the hell Russia has to say? &#8216;Cuz it&#8217;d only be BS anyway. That&#8217;s the US line, brought to us all by neoconservatives, essentially the Democratic Party and progressives. They want to run the world based on rules the US and UK dreamed up after WW2, not on the International Rule of Law as typified by the UN. But the US has demonized the UN so well, Western society thinks it&#8217;s run by amateur nose-pickers. Rule of Law? That only applies within Western country borders, as in Meng is subject to Canadian rule of law here, but China and Russia have to obey US rules-based international order worldwide. Hmm.</p>
<p>To gain at least some minor perspective, I read the Canadian website blog Russia Observer run by Patrick Armstrong, a retired diplomatic staffer who spent years at our Moscow embassy in the past. It&#8217;s a wry but calm commentary on how we manufacture our own BS in the West and disregard anyone else&#8217;s opinions, or even try to understand them. Wouldn&#8217;t help big business in the US&#8217;s attempts to take over the Russkies, and erect wall-to-wall fast food joints there, I guess, while feasting on natural resources if we heard any objections. No wonder Canada agrees with the US official line, or the Yankees would be in here taking us over completely, giving us prime private US medicine and kicking even our socialist Cons, let alone commie Libs and Dippers, to the curb.</p>
<p><a href="https://patrickarmstrong.ca" rel="nofollow ugc">https://patrickarmstrong.ca</a></p>
<p>McPherson sounds like a normal uninformed unrounded pol with opinions. The NDP is as full of them as any other party, I&#8217;m sure.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172497' data-commentid="172497" data-postid="38465" data-belowelement="comment-172497" data-respondelement="respond" data-replyto="Reply to Bill Malcolm" aria-label='Reply to Bill Malcolm'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1">
		<article id="comment-172504" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/91d5db1e6e366f51448958fe2213d38e?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/91d5db1e6e366f51448958fe2213d38e?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Patrick Hertel</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>To elucidate further : <a href="https://www.youtube.com/watch?v=NeSfvA4cCtg" rel="nofollow ugc">https://www.youtube.com/watch?v=NeSfvA4cCtg</a></p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172504' data-commentid="172504" data-postid="38465" data-belowelement="comment-172504" data-respondelement="respond" data-replyto="Reply to Patrick Hertel" aria-label='Reply to Patrick Hertel'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1">
		<article id="comment-172506" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/5d18a10cc64189d32f7d5ba8f72f46a2?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/5d18a10cc64189d32f7d5ba8f72f46a2?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>TENET</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Point taken! But she is my sole soul mate and it must be lonely, hard (especially without a great leader like Mulcair). She is our David in Canada&#8217;s epic struggle with Goliath -we hope, wish her strength&#8230;</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172506' data-commentid="172506" data-postid="38465" data-belowelement="comment-172506" data-respondelement="respond" data-replyto="Reply to TENET" aria-label='Reply to TENET'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1">
		<article id="comment-172513" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/47c52466d10f9c4e38e3723ab7346567?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/47c52466d10f9c4e38e3723ab7346567?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Neil Lore</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Why is NATO still a thing?  Yes Putin&#8217;s a bad man, he&#8217;s no worse than any American president in my lifetime, and better than some.  If the goal was regime change in Russia, wouldn&#8217;t the smart move have been to go in and rebuild it after the cold war?  Kinda like Japan after WWII?  Instead we left a bankrupt failed state to face the Russian winter without a functioning country to take care of them, and, surprise, the power vacuum was filled by the KGB and the Mob.  Why?  Our leaders know that we need an enemy to be scared of, or we&#8217;ll start to ask why our leadership serves a plutocracy, instead of serving their constituency.  We can&#8217;t afford to hire more teachers, or more doctors, or actually take this pandemic seriously, because Putin is a bad man!<br />
While I&#8217;m at it, how is Russia considered a credible enemy?<br />
America&#8217;s GDP 22.2T<br />
China&#8217;s GDP 15.47T<br />
Germany&#8217;s GDP 4.16T<br />
India&#8217;s GDP 3.26T<br />
Canda&#8217;s GDP &#8211; 1.83T<br />
Russia&#8217;s GDP &#8211; 1.67T (#12 overall)<br />
<a href="https://worldpopulationreview.com/countries/countries-by-gdp" rel="nofollow ugc">https://worldpopulationreview.com/countries/countries-by-gdp</a><br />
OooooOOOOooooOOOoooh scary Russians are coming!  We&#8217;d better spend billions of taxpayers dollars containing the big scary threat that is totally NOT contained by the tens of thousands of existing nukes, or the geopolitical reality that Russia can easily be invaded from several different directions, and there is a greater power than Russia in each of those directions.  Even though we hate taxes!  Just in case they forget they are supposed to be our enemy, we&#8217;d better spend even MORE tax dollars to deploy a bunch of NATO troops close to their borders to keep them nervous.  Not that they should be nervous.  Why would Russia even be worried about being invaded?  I&#8217;ve played Risk before and I can tell you that taking Asia is ALWAYS the best way to avoid being attacked. </p>
<p>As for the NDP, they haven&#8217;t been the NDP since Jack Layton convinced them that if they smiled pretty and betrayed their principles, Canadians would let them sit in the big-boy chair.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172513' data-commentid="172513" data-postid="38465" data-belowelement="comment-172513" data-respondelement="respond" data-replyto="Reply to Neil Lore" aria-label='Reply to Neil Lore'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1">
		<article id="comment-172515" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/8d036504b158ea347499ef675020759c?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/8d036504b158ea347499ef675020759c?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Dave in Sask</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>New Democrats in Ottawa can&#8217;t seem to learn that their vote is from progressives.and Tom Mulcair said proved that for them buy saying in 2015 that if the NDP formed government they would balance the budget. That foolishness only cost them 60% of their seats.  People who want a centre right government will vote for the real thing every time which is to say the Liberals.<br />
Ms.  Mcpherson will likely lose her seat and cost the NDP A few other seat was well.</p>
<p>All this will do is hurt the party.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172515' data-commentid="172515" data-postid="38465" data-belowelement="comment-172515" data-respondelement="respond" data-replyto="Reply to Dave in Sask" aria-label='Reply to Dave in Sask'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
<ul class="children">
	<li class="comment odd alt depth-2">
		<article id="comment-172523" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/47c52466d10f9c4e38e3723ab7346567?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/47c52466d10f9c4e38e3723ab7346567?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Neil Lore</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>I think a lot of the damage it did to them was below the waterline, and they haven&#8217;t recovered.  The NDP used to know what it stood for and used to be willing to consistently speak for its values.  Then they decided they wanted to get elected and now they filter everything they say or do through the &#8220;can I be PM if I say or do this&#8221; lens.<br />
The really frustrating thing is that the sequence of events you refer to allowed the Liberals to run on the platform the NDP should have run on, then welch on most of it.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172523' data-commentid="172523" data-postid="38465" data-belowelement="comment-172523" data-respondelement="respond" data-replyto="Reply to Neil Lore" aria-label='Reply to Neil Lore'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment even thread-odd thread-alt depth-1">
		<article id="comment-172520" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/3f6803199dfe217d3727e66afcd79352?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/3f6803199dfe217d3727e66afcd79352?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Bret Larson</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>Have you read her promotional material, that she keeps on sending me (even though she wont reply to my e-mails when Im answering questions she asked me directly).</p>
<p>She seems to believe she is the governing MP for Alberta, some sort of Viceroy for the wokish minded.</p>
<p>Not an MP who is supposed to be representing her Edmonton riding, which I happen to live in.</p>
<p>Pretty sure she has her eye on Rachels crown.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172520' data-commentid="172520" data-postid="38465" data-belowelement="comment-172520" data-respondelement="respond" data-replyto="Reply to Bret Larson" aria-label='Reply to Bret Larson'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
	<li class="comment odd alt thread-even depth-1">
		<article id="comment-172527" class="clearfix">
			<header class="comment-author vcard">
								<!-- custom gravatar call -->
								<img alt='' src='https://secure.gravatar.com/avatar/bf0906f7e255de953bcad1dbd1612f4f?s=75&#038;d=mm&#038;r=r' srcset='https://secure.gravatar.com/avatar/bf0906f7e255de953bcad1dbd1612f4f?s=150&#038;d=mm&#038;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' loading='lazy'/>				<!-- end custom gravatar call -->
				<div class="comment-name"><h4>Scotty on Denman</h4></div>
				<div class="comment-time">April 20th, 2021</div>
			</header>
						<section class="comment_content clearfix">
				<p>The world’s largest Slavic diaspora is located in Canada, the vast majority being Ukrainian, a prominent ethnicity in the Prairie provinces. </p>
<p>Ukraine is the cultural origin of Russia; it became a separate state when the Soviet Union collapsed three decades ago. Russians are the largest ethnicity in Ukraine, prominently in the eastern half of the country where Russia has lately interfered militarily. The Russian spiritual mythos is centred in Ukraine like Kosovo is for Serbs, their fellow Slavs, who invoked their legendary defeat in the “Field of Blackbirds” to justify deadly ethnic cleansing of indigenous Kosovars in 1998–99, late in the decade-long destruction of Yugoslavia. Slavic memory, it appears, is long and deep: the Field of Blackbirds dates back to 1389; Kiev Russ to 882. More recently, the Soviet genocide of the mid 1930s known as the Holodomor is bitterly blamed on Russians by Ukrainians everywhere. </p>
<p>The other element of this story is the New Democratic Party, Canada’s only federated political party (federal and provincial affiliates are coordinated) and most democratic party with respect members getting proposals onto the policy-making agenda, making it distinct from other elected Canadian parties. Dipper policy tends to look, from the outside, like a dog’s breakfast of easy idealism and difficult pragmatism, sometimes so nutty it invites ridicule. This, however, is what real democracy is like, say New Democrats with as much pride as defensiveness —and, sometimes, embarrassment.      </p>
<p>Turn-the-other-cheek shows the gospel socialist half of Dipper parentage, the old trade union half traditionally more likely to answer ridicule with job-action or pick ax handles. This mule has lasted six decades and never won federal government; it gainfully sells itself as the “party of conscience” standing morally askance the two big parties of the centre and right, or ethically astride them when holding the balance of power by which it gets its reason d’être and takes credit for progressive policies (public healthcare, which it achieved by holding a Liberal minority ransom, is practically its motto). Upon this history it stakes its future which seems fairly well assured —many would give the NDP better odds than the CPC surviving as it is today.</p>
<p>The NDP’s provincial affiliates differ by winning governments of varying duration: long in Manitoba and Saskatchewan; short in Nova Scotia, Ontario and Alberta; in between in British Columbia and Yukon Territory.      </p>
<p>Two pertinent facts should be considered before Edmonton NDP MP Heather McPherson’s surprising bellicosity towards Russia: the federal NDP’s brief but glorious shot at winning power, and the Alberta NDP’s stunning upset win which ended eight decades of right-wing government in the Wild Rose province. In baseball terms, together they swept Canadian conservatism in the 2015 double-header (although Mulcair’s pitching had team HarperCon beat, Trudeau was the finisher for the pennant). In boxing terms, both one-two-punch KOs were as anomalous as Ms McPherson’s lone Dipper seat in the home ring of regional conservative blue. </p>
<p>The CPC has limped and ranted like a crazy old soldier of odium ever since, looking, in military terms, quite shell-shocked. The political generals of the Western Prairie have been relieved of their commanding dominance of the party, and a retired Air Command captain from the East, currently where half the CPC seats are, is now leader. Even the Alberta conservative party, which rallied in 2019 to retake the salient, is now looking thin on the ground, strategically and tactically confused, enfeebled, swinging at and missing invisible phantoms while railing ad nauseam, muttering of advanced, magical weapons and Bitumensraum destiny—definitely signs of concussion. They been Dipper-whipped, alright. </p>
<p>The question always  is whether the NDP can achieve more than mere spoiling actions preliminary to giving hard won territory to other parties to exploit.   </p>
<p>The NDP, being federated nationwide, naturally regards provincial successes such as Notley’s 2015 win in Alberta and her Loyal Opposition’s current popularity as potential beechheads for the federal party. McPherson’s objective, therefore, should be to exploit her toe-hold position in the deepest of conservative territory. While aiding provincial sisters and brothers isn’t beyond what might be expected of federal Dippers, Notley’s NDP is already well dug-in with sufficient (and, apparently, growing) fighting capacity to challenge the UCP all by itself; with two years to go until the fixed election date, Notley might be observing Napoleon’s rule: “When your enemy is executing a false movement [making a mistake], never interrupt him.” Still, winning any affection for the NDP from the considerable number of ethnic Ukrainians in Alberta —McPherson’s apparent ploy in siding with Ukraine against Russian aggression, an emotional issue for Ukrainians everywhere—at least couldn’t hurt the provincial NDP, even though, strictly speaking, this international matter is far beyond its jurisdiction. </p>
<p>Rather, I think, the Edmonton MP’s objective is to garner nationwide affection for the NDP from Ukrainian-Canadians, if not for her own prospects from Ukrainian-Albertans. It seems unlikely the ploy is intended to win the Dippers more federal seats in Alberta. But it might also be an intentional feint to goad intemperate reaction from federal (and possibly Albertan) conservatives, a strong likelihood given their moody, delusional blaming and blubbering dejection these days—and odds it won’t get any better anytime soon. It couldn’t get much easier than it is now to push unflattering buttons on the hot-flashing, out-gassing neo-rightsts and reliably irritable SoCons. What’s bad for an enemy is good for a friend.    </p>
<p>But there’s a risk, probably slight for McPherson since she’s not party leader, that any policy move perceived as rightward by Dipper ideologues—the kind that propose immobilizing the armed forces or ending capitalism—can earn the kind of ideologically overdone, righteous indignation that got Mulcair—whose leadership won the second largest number of Dipper seats in party history (second only to Jack Layton’s historic Loyal Opposition from whom the mantle was passed), who made the party the most popular in the country for the very first time, who showed citizens how to mop the Commons floor with an intransigently dishonest Prime Minister, and who very nearly became PM himself—unceremoniously and thanklessly rejected when the party was returned to the third-party status its apologists are ever-eager to rationalize as honourable and conscientious. Sometimes all you can do is shake your head (I know I did—and I’m a party member!) </p>
<p>Again, McPherson doesn’t need to worry about the problems of leading such an ideological party, but I suspect she might get criticized by her partisan rivals (in Alberta that means conservatives, federal and provincial) for attempting to play Ukrainian-Albertans or Ukrainian-Canadians for personal or partisan gain. That is, if punch-drunk conservatives don’t knee-jerk accuse her of being a communist traitor or foreign environmentalist or Bigfoot or something more in keeping with their current intemperance.   </p>
<p>I concur: if McPherson expects to blunt typical criticism from right-wing media with her atypical saber-rattling, I expect she’ll be disappointed. But, for a party that infamously overthinks everything, I doubt it’d be so thoughtlessly trite. At least I should hope.</p>
				<a rel='nofollow' class='comment-reply-link' href='#comment-172527' data-commentid="172527" data-postid="38465" data-belowelement="comment-172527" data-respondelement="respond" data-replyto="Reply to Scotty on Denman" aria-label='Reply to Scotty on Denman'>Reply</a>							</section>
			
		</article>
	<!-- </li> is added by WordPress automatically -->
</li><!-- #comment-## -->
</ol>
<nav id="comment-nav">
	<ul class="clearfix">
		<li>
					</li>
		<li>
					</li>
	</ul>
</nav>
<section id="respond" class="respond-form">
	<h3 id="comment-form-title">
		Leave a Reply	</h3>
	<div id="cancel-comment-reply">
		<p class="small">
			<a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=there-are-better-ways-for-albertas-only-new-democrat-to-spend-her-time-than-calling-for-more-canadian-troops-on-russias-doorstep#respond" style="display:none;">Click here to cancel reply.</a>		</p>
	</div>
		<form action="https://albertapolitics.ca/wp-comments-post.php" method="post" id="commentform">
				<ul id="comment-form-elements" class="clearfix">
			<li>
				<label for="author">
					Name					(required)				</label>
				<input type="text" name="author" id="author" value="" placeholder="Your Name*" tabindex="1" aria-required='true' />
			</li>
			<li>
				<label for="email">
					Mail					(required)				</label>
				<small>
				(not be published)				</small>
				<input type="email" name="email" id="email" value="" placeholder="Your E-Mail*" tabindex="2" aria-required='true' />
			</li>
			<li>
				<label for="url">
					Website				</label>
				<input type="url" name="url" id="url" value="" placeholder="Got a website?" tabindex="3" />
			</li>
		</ul>
				<p>
			<textarea name="comment" id="comment" placeholder="Your Comment here..." tabindex="4"></textarea>
		</p>
		<input name="submit" type="submit" id="submit" class="btn btn-primary" tabindex="5" value="Submit" />
		<input type='hidden' name='comment_post_ID' value='38465' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
		<!--<div class="alert alert-info">
		<p id="allowed_tags" class="small"><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></p>
	</div>-->
			</form>
	</section>
			</article>
			<!-- end article -->
								</div>
		<div class="sidebar">
			<div class="sidebar-inside">
		<div id="search-4" class="widget widget_search"><form method="get" class="form-search" action="https://albertapolitics.ca/">
		<div class="col-lg-12">
			<div class="input-group">
				<input type="text" class="form-control search-query" name="s" placeholder="Looking for something">
				<span class="input-group-btn">
					<button type="submit" class="btn btn-primary" name="submit" id="searchsubmit" value="Go">Search</button>
				</span>
			</div>
		</div>
</form></div><div id="adwidget_imagewidget-6" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.stoppsecuts.ca/' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Province-Wide-Ad-1.png' alt='Ad' /></a></div><div id="text-3" class="widget widget_text"><div class="widgettitle-wrapper"><h3 class="widgettitle">Support ALBERTAPOLITICS.CA</h3></div>			<div class="textwidget"><p><center><a title="PayPal Donate" href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&amp;business=GZM2XBGM3G3S4&amp;lc=CA&amp;item_name=Alberta%20Diary%20Blog&amp;currency_code=CAD&amp;bn=PP%2dDonationsBF%3abtn_donateCC_LG%2egif%3aNonHosted" target="_blank" rel="noopener"><img src="https://albertapolitics.ca/wp-content/uploads/2014/12/paypal_donate.jpeg" alt="PayPal Donate Button" /></a></center></p>
</div>
		</div><div id="adwidget_imagewidget-8" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.parklandinstitute.ca/alberta_budget_2021' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Budget-ad2Flavio-1.jpg' alt='Ad' /></a></div><div id="extended-categories-3" class="widget widget_extended-categories"><!-- AVH Extended Categories version 3.10.0-dev.1 | http://blog.avirtualhome.com/wordpress-plugins/ --><div class="widgettitle-wrapper"><h3 class="widgettitle">Categories</h3></div><ul>	<li class="cat-item cat-item-4 current-cat"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/canadian-politics/" title="View all posts filed under Canadian Politics">Canadian Politics</a><div class="avhec-widget-count"> (362)</div></div>
</li>
	<li class="cat-item cat-item-214"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/st-albert/" title="View all posts filed under St. Albert">St. Albert</a><div class="avhec-widget-count"> (26)</div></div>
</li>
	<li class="cat-item cat-item-350"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/geopolitics/" title="View all posts filed under Geopolitics">Geopolitics</a><div class="avhec-widget-count"> (68)</div></div>
</li>
	<li class="cat-item cat-item-393"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/news-satire/" title="View all posts filed under News Satire">News Satire</a><div class="avhec-widget-count"> (5)</div></div>
</li>
	<li class="cat-item cat-item-396"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/alberta-politics-2/" title="View all posts filed under Alberta Politics">Alberta Politics</a><div class="avhec-widget-count"> (1,751)</div></div>
</li>
	<li class="cat-item cat-item-405"><div class="avhec-widget-line"><a href="https://albertapolitics.ca/category/media-2/" title="View all posts filed under Media">Media</a><div class="avhec-widget-count"> (33)</div></div>
</li>
</ul></div><div id="adwidget_imagewidget-9" class="widget AdWidget_ImageWidget"><a target="_blank" href='https://www.parklandinstitute.ca/dentistry_in_alberta' alt='Ad'><img style='width: 100%;' src='https://albertapolitics.ca/wp-content/uploads/Blog-ad-1.jpg ' alt='Ad' /></a></div>	</div>		</div>
	</div>
</div>
</div>
<div class="wrapper-footer">
	<footer class="footer">
			<div class="container-footer">
				<div class="footer-widgetwrapper">
						<div class="col-md-3">
																				</div>
						<div class="col-md-3">
							
													</div>
						<div class="col-md-3">
							
													</div>
						<div class="col-md-3">
							
													</div>
				</div>
			</div>
			<div class="slidefooter-trigger"> </div>
			<div id="slidebox"> <a class="slide-close"><img src="https://albertapolitics.ca/wp-content/themes/ilovenews/images/slide-close.png"  width="30" height="30" id="roti3" alt="pane"/> </a>
  <div class="slidebox-inner">
    <div class="slider-placecontent">
        
            </div>
  </div>
</div>		<div id="container-footer7">
			<div id="inner-footer" class="wrap clearfix">
			<div class="footer7-navwrapper">
					<div class="footer7-navbottom">
						<ul id="menu-footer-menu" class="nav navbar-nav"><li id="menu-item-26751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://albertapolitics.ca/">Home</a></li>
<li id="menu-item-26750" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/about-the-author/">About the Author</a></li>
<li id="menu-item-26748" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/donate/">Donate</a></li>
<li id="menu-item-26745" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://albertapolitics.ca/privacy-policy/">Privacy Policy</a></li>
</ul>					</div>		
					
					<div class="footer7-copyright">
																© Copyright 2020 - Alberta Politics.													</div>
					</div>
					<div class="footer7-logowrapper"> 
					<div class="footer7-logo"> <a href=" "> <img src="/wp-content/uploads/upfw/albertapoliticslogo-small.png " alt="Alberta Politics"> </a>
					</div>
					</div>
						

			</div>
		</div>		
	</footer>
</div>
<!-- end .wrapper -->
<div class="back-top">
	<a href="#top"><span><i class="fa fa-angle-up fa-2x"></i></span></a>
</div>
	<style type="text/css"></style><link rel='stylesheet' id='js_composer_front_cus-css'  href='https://albertapolitics.ca/wp-content/plugins/js_composer/assets/css/js_composer.css?ver=5.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' defer onload='' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0' defer onload='"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0' defer onload='"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0' defer onload='"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4' defer onload='"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12' defer onload='"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://albertapolitics.ca/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2' defer onload='"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/i18n.min.js?ver=ac389435e7fd4ded01cf603f3aaba6a6' defer onload='' id='wp-i18n-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' defer onload='' id='lodash-js'></script>
<script type='text/javascript' id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/url.min.js?ver=98645f0502e5ed8dadffd161e39072d2' defer onload='' id='wp-url-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/hooks.min.js?ver=84b89ab09cbfb4469f02183611cc0939' defer onload='' id='wp-hooks-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", {"translation-revision-date":"2021-04-15 04:13:20+0000","generator":"GlotPress\/3.0.0-alpha.2","domain":"messages","locale_data":{"messages":{"":{"domain":"messages","plural-forms":"nplurals=2; plural=n != 1;","lang":"en_CA"},"You are probably offline.":["You are probably offline."],"Media upload failed. If this is a photo or a large image, please scale it down and try again.":["Media upload failed. If this is a photo or a large image, please scale it down and try again."],"An unknown error occurred.":["An unknown error occurred."],"The response is not a valid JSON response.":["The response is not a valid JSON response."]}},"comment":{"reference":"wp-includes\/js\/dist\/api-fetch.js"}} );
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/dist/api-fetch.min.js?ver=4dec825c071b87c57f687eb90f7c23c3' defer onload='' id='wp-api-fetch-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://albertapolitics.ca/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "d8ba9d4c2e" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://albertapolitics.ca/wp-admin/admin-ajax.php?action=rest-nonce";
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.4' defer onload='' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/jquery.nouislider.min.js?ver=1.9' defer onload='' id='nouislider-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/jquery.appear.js?ver=2.0.4' defer onload='' id='appear-js'></script>
<script type='text/javascript' id='review-js-extra'>
/* <![CDATA[ */
var ajax_user_rate = {"url":"https:\/\/albertapolitics.ca\/wp-admin\/admin-ajax.php","nonce":"0e169bf360"};
/* ]]> */
</script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/plugins/sama-author-review/assets/js/review.js?ver=1.9' defer onload='' id='review-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/scripts.js?ver=1.1' defer onload='' id='bones-js-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/modernizr.custom.min.js?ver=1.1' defer onload='' id='bones-modernizr-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/bootstrap.min.js?ver=1.1' defer onload='' id='bones-bootstrap-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/fitvids.js?ver=1.1' defer onload='' id='fitvids-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.columnizer.js?ver=1.1' defer onload='' id='columnizer-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/theia-sticky-sidebar-min.js?ver=1.1' defer onload='' id='theia-sticky-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/wookmark.js?ver=1.1' defer onload='' id='wookmark-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/imagesloaded.min.js?ver=4.1.4' defer onload='' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/masonry.min.js?ver=4.2.2' defer onload='' id='masonry-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/inview.js?ver=1.1' defer onload='' id='inview-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/carouselfred.js?ver=1.1' defer onload='' id='carouselfred-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/viewportchecker.js?ver=1.1' defer onload='' id='viewportchecker-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.countTo.js?ver=1.1' defer onload='' id='countTo-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-content/themes/ilovenews/library/js/libs/jquery.easypiechart.min.js?ver=1.1' defer onload='' id='easypiechart-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/comment-reply.min.js?ver=5.6.3' defer onload='' id='comment-reply-js'></script>
<script type='text/javascript' src='https://albertapolitics.ca/wp-includes/js/wp-embed.min.js?ver=5.6.3' defer onload='' id='wp-embed-js'></script>
</body></html>